summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-standalone/recipes-standalone
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:25:29 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-12 01:25:34 +0300
commit10fa14942b9cb27780f9496382107516639208b4 (patch)
treef4b195505178e47c4b21ece7b3a898d9402b2daa /meta-xilinx/meta-xilinx-standalone/recipes-standalone
parent6d8913e6c02e578d4e41b7fe88113f4e4822992d (diff)
downloadopenbmc-10fa14942b9cb27780f9496382107516639208b4.tar.xz
meta-xilinx: subtree update:569f52f275..b3e37df5d9
Mark Hatle (11): meta-microblaze: Move gcc patch that was missed in the prior work Uprev standalone toolchain bbappends pmu-firmware: Latest toolchain always treats 'assert' as a macro binutils: update to early gatesgarth version gdb: update to early gatesgarth version gcc: update to early gatesgarth version newlib: update to early gatesgarth version machine/aarch64-tc.conf: Fix incorrect ilp32 pkgarch libgcc.bbappend: Clear empty lib directory newlib: Upstream now disabled builtin symbols gdb: Fix on-target GDB compilation Sai Hari Chandana Kalluri (5): linux-xlnx_2020.2: Fix previous git cherry-pick xrt: Remove stale patch to fix endian issues with latest version of boost opencl-clhpp, ocl-icd: Remove recipes from meta-xilinx esw.bbclass: Remove trailing / after S Remove recipe bbappends pointing to older versions Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I18b028388a5b55a49ef135b98290228fa797e38d
Diffstat (limited to 'meta-xilinx/meta-xilinx-standalone/recipes-standalone')
-rw-r--r--meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch68
-rw-r--r--meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2020.2.bb3
2 files changed, 70 insertions, 1 deletions
diff --git a/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch b/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch
new file mode 100644
index 000000000..87e1b111b
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware/fix-zynqmp-assert.patch
@@ -0,0 +1,68 @@
+diff --git a/lib/sw_apps/zynqmp_pmufw/src/pm_reset.c b/lib/sw_apps/zynqmp_pmufw/src/pm_reset.c
+index 297c6c2ddc..bc295cf013 100644
+--- a/lib/sw_apps/zynqmp_pmufw/src/pm_reset.c
++++ b/lib/sw_apps/zynqmp_pmufw/src/pm_reset.c
+@@ -52,7 +52,7 @@
+ * @pulse Function performing reset pulse operation
+ */
+ typedef struct PmResetOps {
+- void (*const assert)(const PmReset* const rst, const u32 action);
++ void (*const resetAssert)(const PmReset* const rst, const u32 action);
+ u32 (*const getStatus)(const PmReset* const s);
+ u32 (*const pulse)(const PmReset* const rst);
+ } PmResetOps;
+@@ -415,37 +415,37 @@ static u32 PmResetPulsePl(const PmReset* const rst)
+ }
+
+ static const PmResetOps pmResetOpsGeneric = {
+- .assert = PmResetAssertGen,
++ .resetAssert = PmResetAssertGen,
+ .getStatus = PmResetGetStatusGen,
+ .pulse = PmResetPulseGen,
+ };
+
+ static const PmResetOps pmResetOpsGpo = {
+- .assert = PmResetAssertGpo,
++ .resetAssert = PmResetAssertGpo,
+ .getStatus = PmResetGetStatusGpo,
+ .pulse = PmResetPulseGpo,
+ };
+
+ static const PmResetOps pmResetOpsRom = {
+- .assert = PmResetAssertRom,
++ .resetAssert = PmResetAssertRom,
+ .getStatus = PmResetGetStatusRom,
+ .pulse = PmResetPulseRom,
+ };
+
+ static const PmResetOps pmResetOpsNoAssert = {
+- .assert = NULL,
++ .resetAssert = NULL,
+ .getStatus = PmResetGetStatusRom,
+ .pulse = PmResetPulseRom,
+ };
+
+ static const PmResetOps pmResetOpsPl = {
+- .assert = PmResetAssertPl,
++ .resetAssert = PmResetAssertPl,
+ .getStatus = PmResetGetStatusPl,
+ .pulse = PmResetPulsePl,
+ };
+
+ static const PmResetOps pmResetOpsGpioBankIO = {
+- .assert = NULL,
++ .resetAssert = NULL,
+ .getStatus = PmResetGetStatusGpioBankIOs,
+ .pulse = PmResetPulseGpioBankIOs,
+ };
+@@ -1901,8 +1901,8 @@ s32 PmResetDoAssert(const PmReset *reset, u32 action)
+ switch (action) {
+ case PM_RESET_ACTION_RELEASE:
+ case PM_RESET_ACTION_ASSERT:
+- if (NULL != reset->ops->assert) {
+- reset->ops->assert(reset, action);
++ if (NULL != reset->ops->resetAssert) {
++ reset->ops->resetAssert(reset, action);
+ } else {
+ status = XST_INVALID_PARAM;
+ }
diff --git a/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2020.2.bb b/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2020.2.bb
index 652241c0a..330e02095 100644
--- a/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2020.2.bb
+++ b/meta-xilinx/meta-xilinx-standalone/recipes-standalone/pmu-firmware/pmu-firmware_2020.2.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://../../../../license.txt;md5=39ab6ab638f4d1836ba994ec6
SRCREV = "e8db5fb118229fdc621e0ec7848641a23bf60998"
PV = "${XILINX_RELEASE_VERSION}+git${SRCPV}"
-SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1"
+SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1 \
+ file://fix-zynqmp-assert.patch;pnum=5"
COMPATIBLE_HOST = "microblaze.*-elf"
COMPATIBLE_MACHINE = "microblaze-pmu"