summaryrefslogtreecommitdiff
path: root/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-24 20:35:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-04 14:55:03 +0300
commit22dfccd0e9c7dc73baa534784d565992a8920d66 (patch)
tree7c8b91e09f2dda317460f174751846974ae31359 /meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
parent9549b565df99938a28204ef45f924743f06bb5d5 (diff)
downloadopenbmc-22dfccd0e9c7dc73baa534784d565992a8920d66.tar.xz
meta-yadro: vesnin: new YAML dependency scheme
All the IPMI virtuals and PREFERRED_PROVIDERS in meta-phosphor are in the process of being deprecated. Prepare for that and move to a simpler scheme for providing the YAML configuration for Vesnin systems. (From meta-yadro rev: 9c29d1b377aafa400444273bfb7fdd28b0803f34) Change-Id: Id243bb4e0f2c742ebb1124195a16b9ce20856091 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb')
-rw-r--r--meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb b/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
new file mode 100644
index 000000000..dc786e562
--- /dev/null
+++ b/meta-yadro/meta-vesnin/recipes-phosphor/configuration/vesnin-yaml-config.bb
@@ -0,0 +1,23 @@
+SUMMARY = "YAML configuration for Vesnin"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${YADROBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+
+SRC_URI = " \
+ file://vesnin-ipmi-fru.yaml \
+ "
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -m 0644 -D vesnin-ipmi-fru.yaml \
+ ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
+}
+
+FILES_${PN}-dev = " \
+ ${datadir}/${BPN}/ipmi-fru-read.yaml \
+ "
+
+ALLOW_EMPTY_${PN} = "1"