summaryrefslogtreecommitdiff
path: root/meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-14 19:33:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-14 19:36:35 +0300
commitc9ed720bc2866798691af342289c4b5d03203d33 (patch)
treed4423e645b59d5cd3ec6d6f9b7f0e3107d13d220 /meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb
parentd74a47d9af60c43ad045b983cbfd4db518b776cc (diff)
downloadopenbmc-c9ed720bc2866798691af342289c4b5d03203d33.tar.xz
meta-yadro: add subtree
Alexander Filippov (4): Initial commit meta-yadro: Initial version of meta-vesnin layer meta-yadro: Add readme files meta-vesnin: Use VESNIN DTS from kernel repo Change-Id: Ifa6f1ad3890af4800d27a76fb709e8f8d91295df Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb')
-rw-r--r--meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb b/meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..efea9368a
--- /dev/null
+++ b/meta-yadro/meta-vesnin/recipes-phosphor/ipmi/vesnin-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Vesnin IPMI to DBus Inventory mapping."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${YADROBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}