summaryrefslogtreecommitdiff
path: root/poky/meta-selftest/recipes-test/images
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /poky/meta-selftest/recipes-test/images
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'poky/meta-selftest/recipes-test/images')
-rw-r--r--poky/meta-selftest/recipes-test/images/error-image.bb8
-rw-r--r--poky/meta-selftest/recipes-test/images/oe-selftest-image.bb9
-rw-r--r--poky/meta-selftest/recipes-test/images/test-empty-image.bb6
-rw-r--r--poky/meta-selftest/recipes-test/images/wic-image-minimal.bb15
-rw-r--r--poky/meta-selftest/recipes-test/images/wic-image-minimal.wks10
5 files changed, 48 insertions, 0 deletions
diff --git a/poky/meta-selftest/recipes-test/images/error-image.bb b/poky/meta-selftest/recipes-test/images/error-image.bb
new file mode 100644
index 000000000..13d9cc010
--- /dev/null
+++ b/poky/meta-selftest/recipes-test/images/error-image.bb
@@ -0,0 +1,8 @@
+SUMMARY = "An image that includes the error recipe and will therefore fail"
+DESCRIPTION = "This generates an error. Not currently used by oe-selftest"
+
+IMAGE_INSTALL = "error"
+
+IMAGE_LINGUAS = " "
+
+inherit core-image
diff --git a/poky/meta-selftest/recipes-test/images/oe-selftest-image.bb b/poky/meta-selftest/recipes-test/images/oe-selftest-image.bb
new file mode 100644
index 000000000..5d4d10eef
--- /dev/null
+++ b/poky/meta-selftest/recipes-test/images/oe-selftest-image.bb
@@ -0,0 +1,9 @@
+SUMMARY = "An image used during oe-selftest tests"
+
+IMAGE_INSTALL = "packagegroup-core-boot dropbear"
+IMAGE_FEATURES = "debug-tweaks"
+
+IMAGE_LINGUAS = " "
+
+inherit core-image
+
diff --git a/poky/meta-selftest/recipes-test/images/test-empty-image.bb b/poky/meta-selftest/recipes-test/images/test-empty-image.bb
new file mode 100644
index 000000000..88d8d612e
--- /dev/null
+++ b/poky/meta-selftest/recipes-test/images/test-empty-image.bb
@@ -0,0 +1,6 @@
+SUMMARY = "An empty image."
+IMAGE_INSTALL = ""
+IMAGE_LINGUAS = ""
+PACKAGE_INSTALL = ""
+
+inherit image
diff --git a/poky/meta-selftest/recipes-test/images/wic-image-minimal.bb b/poky/meta-selftest/recipes-test/images/wic-image-minimal.bb
new file mode 100644
index 000000000..e1da203b5
--- /dev/null
+++ b/poky/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -0,0 +1,15 @@
+SUMMARY = "An example of partitioned image."
+
+SRC_URI = "file://${FILE_DIRNAME}/${BPN}.wks"
+
+IMAGE_INSTALL = "packagegroup-core-boot"
+
+IMAGE_FSTYPES = "wic"
+
+WKS_FILE_DEPENDS = "syslinux syslinux-native dosfstools-native mtools-native gptfdisk-native"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+IMAGE_ROOTFS_EXTRA_SPACE = "2000"
+
+inherit image
diff --git a/poky/meta-selftest/recipes-test/images/wic-image-minimal.wks b/poky/meta-selftest/recipes-test/images/wic-image-minimal.wks
new file mode 100644
index 000000000..ae69cb6e3
--- /dev/null
+++ b/poky/meta-selftest/recipes-test/images/wic-image-minimal.wks
@@ -0,0 +1,10 @@
+# short-description: Example of partitioned image with complex layout
+# long-description: This image contains boot partition and 3 rootfs partitions
+# created from core-image-minimal and wic-image-minimal image recipes.
+
+part /boot --source bootimg-pcbios --ondisk sda --label boot --active --align 1024
+part / --source rootfs --ondisk sda --fstype=ext4 --label platform --align 1024 --use-uuid
+part /media --source rootfs --rootfs-dir=wic-image-minimal --ondisk sda --fstype=ext4 --label uuid-test --align 1024 --use-uuid --fsuuid 2c71ef06-a81d-4735-9d3a-379b69c6bdba
+part /mnt --source rootfs --rootfs-dir=wic-image-minimal --ondisk sda --fstype=ext4 --label core --align 1024
+
+bootloader --ptable gpt --timeout=0 --append="rootwait console=tty0"