summaryrefslogtreecommitdiff
path: root/poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
commit98cc5cd6483975b64d80e8323f7f659dd1337d75 (patch)
tree5fa64e93d57396bc4c76aa3537156205b4b424ac /poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
parent82dbc15a05125a812c140a3c8cff81c366482229 (diff)
parent8fc454f9beebdd347403145c991697019a593cff (diff)
downloadopenbmc-98cc5cd6483975b64d80e8323f7f659dd1337d75.tar.xz
Merge tag '0.29' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb')
-rw-r--r--poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
index 3acc523a8..946a12d0a 100644
--- a/poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ b/poky/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
@@ -8,7 +8,7 @@ PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
# The following variables should be set to accomodate each application
BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}"
@@ -40,8 +40,8 @@ EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
# Install binaries on the proper location for baremetal-image to fetch and deploy
do_install(){
install -d ${D}/${base_libdir}/firmware
- install -m 755 ${B}build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
- install -m 755 ${B}build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
+ install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
+ install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
}
FILES_${PN} += " \