summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
commitda710c8bb0dea17982efc20ab4ee226a86992e6f (patch)
tree06c83c9e85c881f40532972aaa1453298236e029 /poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb
parent6656af78e6c7b48a1252459a61b3b72dce77ab44 (diff)
parent2795589128d1f7509ac0ab9eba940d868413ac7d (diff)
downloadopenbmc-da710c8bb0dea17982efc20ab4ee226a86992e6f.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb')
-rw-r--r--poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb b/poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb
new file mode 100644
index 000000000..797db738f
--- /dev/null
+++ b/poky/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "C implementation of createrepo."
+HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ "
+
+SRCREV = "bc67f19ed09593e3886ebeee2391e9d51cc3439f"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
+DEPENDS_append_class-native = " file-replacement-native"
+
+inherit cmake pkgconfig bash-completion distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
+}
+
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
+ rm -rf ${D}/etc
+}