summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
commitda710c8bb0dea17982efc20ab4ee226a86992e6f (patch)
tree06c83c9e85c881f40532972aaa1453298236e029 /poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb
parent6656af78e6c7b48a1252459a61b3b72dce77ab44 (diff)
parent2795589128d1f7509ac0ab9eba940d868413ac7d (diff)
downloadopenbmc-da710c8bb0dea17982efc20ab4ee226a86992e6f.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb')
-rw-r--r--poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb b/poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb
new file mode 100644
index 000000000..d70757a15
--- /dev/null
+++ b/poky/meta/recipes-devtools/gdb/gdb_8.3.1.bb
@@ -0,0 +1,28 @@
+require gdb.inc
+require gdb-${PV}.inc
+
+inherit python3-dir
+
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ gl_cv_func_working_strerror=yes \
+ gl_cv_func_strerror_0_works=yes \
+ gl_cv_func_gettimeofday_clobber=no \
+ "
+
+do_configure_prepend() {
+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
+ cat > ${WORKDIR}/python << EOF
+#!/bin/sh
+case "\$2" in
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
+ --exec-prefix) echo "${exec_prefix}" ;;
+ *) exit 1 ;;
+esac
+exit 0
+EOF
+ chmod +x ${WORKDIR}/python
+ fi
+}