summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
commit36caa12533da01d4319c5ffe7613711a0ec7dea7 (patch)
tree591c2077bb14cfd9d23893d32cca71fa7a01bc9c /poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
parent12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (diff)
parent3cec7f5a630c1ddcad058eb76e1f732a5fa20d59 (diff)
downloadopenbmc-36caa12533da01d4319c5ffe7613711a0ec7dea7.tar.xz
Merge tag '0.45' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-packaging_20.9.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-packaging_20.9.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb b/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
new file mode 100644
index 000000000..92cf6a25f
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-packaging_20.9.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[sha256sum] = "5b327ac1320dc863dca72f4514ecc086f31186744b84a230374cc1fd776feae5"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"