summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadopenbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.xz
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb')
-rw-r--r--yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb b/yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb
new file mode 100644
index 000000000..169d00581
--- /dev/null
+++ b/yocto-poky/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Configuration script to export target rootfs filesystem"
+DESCRIPTION = "Enables NFS access from any host to the entire filesystem (for development purposes)."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r1"
+
+SRC_URI = "file://exports"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 exports ${D}${sysconfdir}/
+}
+
+RDEPENDS_${PN} = "packagegroup-core-nfs-server"