summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadopenbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.xz
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb b/yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb
new file mode 100644
index 000000000..cbaf05436
--- /dev/null
+++ b/yocto-poky/meta/recipes-graphics/matchbox-session/matchbox-session_0.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Custom Matchbox session files"
+HOMEPAGE = "http://www.matchbox-project.org/"
+BUGTRACKER = "http://bugzilla.yoctoproject.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea"
+
+SECTION = "x11"
+RCONFLICTS_${PN} = "matchbox-common"
+
+SRC_URI = "file://matchbox-session"
+S = "${WORKDIR}"
+
+PR = "r4"
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "x-session-manager"
+ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matchbox-session ${D}/${bindir}
+}