summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadopenbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.xz
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb b/yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb
new file mode 100644
index 000000000..c0345178c
--- /dev/null
+++ b/yocto-poky/meta/recipes-graphics/mesa/mesa_git.bb
@@ -0,0 +1,22 @@
+require ${BPN}.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SRCREV = "ea0d1f575c214c09ba3df12644a960e86e031766"
+PV = "10.5.4+git${SRCPV}"
+
+SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;branch=10.5"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "python-mako-native"
+
+inherit pythonnative
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}