summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadopenbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.xz
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb b/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
new file mode 100644
index 000000000..c53f1b758
--- /dev/null
+++ b/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+SUMMARY = "X11 display server"
+LICENSE = "MIT"
+PR = "r40"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup distro_features_check
+# rdepends on XSERVER
+REQUIRED_DISTRO_FEATURES = "x11"
+
+XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVERCODECS ?= ""
+
+RDEPENDS_${PN} = "\
+ ${XSERVER} \
+ ${XSERVERCODECS} \
+ "