summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-support/lz4/lz4.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 22:41:29 +0300
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-support/lz4/lz4.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadopenbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.xz
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-support/lz4/lz4.bb')
-rw-r--r--yocto-poky/meta/recipes-support/lz4/lz4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-support/lz4/lz4.bb b/yocto-poky/meta/recipes-support/lz4/lz4.bb
new file mode 100644
index 000000000..18e56d04c
--- /dev/null
+++ b/yocto-poky/meta/recipes-support/lz4/lz4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=0b0d063f37a4477b54af2459477dcafd"
+
+SRCREV = "d86dc916771c126afb797637dda9f6421c0cb998"
+
+PV = "131+git${SRCPV}"
+
+SRC_URI = "git://github.com/Cyan4973/lz4.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+
+do_install() {
+ oe_runmake install
+}
+
+BBCLASSEXTEND += "native nativesdk"