summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb b/import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb
index c5aff6616..562170694 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/gd/gd_2.2.3.bb
@@ -13,7 +13,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
DEPENDS = "freetype libpng jpeg zlib tiff"
SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
- file://fix-gcc-unused-functions.patch"
+ file://fix-gcc-unused-functions.patch \
+ file://CVE-2016-10166.patch \
+ file://CVE-2016-10167.patch \
+ file://CVE-2016-10168.patch \
+ file://.gitignore-the-new-test-case.patch \
+ file://Fix-290-TGA-RLE-decoding-is-broken.patch;apply=no \
+ file://CVE-2016-6906-1.patch;apply=no \
+ file://CVE-2016-6906-2.patch;apply=no"
SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c"
@@ -32,6 +39,19 @@ EXTRA_OECONF += " --disable-rpath \
EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+do_git_apply () {
+ cd ${S}
+ if [ ! -f tests/tga/tga_read_rgb.png ]; then
+ git apply ${S}/../Fix-290-TGA-RLE-decoding-is-broken.patch
+ git apply ${S}/../CVE-2016-6906-1.patch
+ git apply ${S}/../CVE-2016-6906-2.patch
+ fi
+}
+
+do_patch_append() {
+ bb.build.exec_func('do_git_apply', d)
+}
+
do_install_append() {
# cleanup buildpaths from gdlib.pc
sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc