summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch38
1 files changed, 29 insertions, 9 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch b/import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
index 71963e0c4..5b7b6966a 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
+++ b/import-layers/meta-openembedded/meta-oe/recipes-support/multipath-tools/files/makefile_inc.patch
@@ -1,4 +1,8 @@
-multipath-tools: modify Makefile.inc for cross-compilation
+From 9f5768eca165502b0f17d271aa6f7cf530ec60b2 Mon Sep 17 00:00:00 2001
+From: Joe Slater <joe.slater@windriver.com>
+Date: Mon, 22 Sep 2014 17:22:32 -0700
+Subject: [PATCH] multipath-tools: modify Makefile.inc for
+ cross-compilation
Do not look for systemd info on the host, and allow us to pass in CFLAGS
using the OPTFLAGS variable.
@@ -10,10 +14,15 @@ Signed-off-by: Joe Slater <joe.slater@windriver.com>
Update for version 0.5.0-144-g770e6d0
Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ Makefile.inc | 17 +++++------------
+ 1 file changed, 5 insertions(+), 12 deletions(-)
+diff --git a/Makefile.inc b/Makefile.inc
+index 1cc8f44..15f8b91 100644
--- a/Makefile.inc
+++ b/Makefile.inc
-@@ -21,12 +21,6 @@ ifndef LIB
+@@ -29,12 +29,6 @@ ifndef RUN
endif
endif
@@ -26,14 +35,25 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
ifndef SYSTEMDPATH
SYSTEMDPATH=usr/lib
endif
-@@ -53,7 +47,10 @@ ifndef RPM_OPT_FLAGS
- RPM_OPT_FLAGS = -O2 -g -pipe -Wformat-security -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
- endif
+@@ -61,13 +55,12 @@ RM = rm -f
+ LN = ln -sf
+ INSTALL_PROGRAM = install
+-OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 \
+- -Wno-sign-compare -Wno-unused-parameter -Wno-clobbered \
+- -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector \
+- --param=ssp-buffer-size=4
+ifndef OPTFLAGS
- OPTFLAGS = $(RPM_OPT_FLAGS) -Wunused -Wstrict-prototypes
++OPTFLAGS = $(RPM_OPT_FLAGS) -Wunused -Wstrict-prototypes
+endif
-+
- CFLAGS = $(OPTFLAGS) -fPIC -DLIB_STRING=\"${LIB}\"
- SHARED_FLAGS = -shared
+-CFLAGS = $(OPTFLAGS) -fPIC -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
+-SHARED_FLAGS = -shared
++CFLAGS = $(OPTFLAGS) -fPIC -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
++SHARED_FLAGS = -shared
+
+ %.o: %.c
+ $(CC) $(CFLAGS) -c -o $@ $<
+--
+2.11.0
+