summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r--import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc9
1 files changed, 6 insertions, 3 deletions
diff --git a/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc b/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
index 6140250ca..4feb9a03c 100644
--- a/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
@@ -3,18 +3,21 @@ HOMEPAGE = "http://pytest.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4"
-SRC_URI[md5sum] = "401c005bd57f71e63ba015ab086fe67d"
-SRC_URI[sha256sum] = "f46e49e0340a532764991c498244a60e3a37d7424a532b3ff1a6a7653f1a403a"
+SRC_URI[md5sum] = "1b83a25d45fad893f430fc5031653c56"
+SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad5903eb8c5"
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
file://pytest_version_fix.patch "
RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-doctest \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-pluggy \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"