summaryrefslogtreecommitdiff
path: root/import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb')
-rw-r--r--import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb b/import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb
index 073022e5c..641d55fc1 100644
--- a/import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb
+++ b/import-layers/meta-virtualization/recipes-networking/netns/netns_git.bb
@@ -2,19 +2,19 @@ HOMEPAGE = "https://github.com/jfrazelle/netns"
SUMMARY = "Runc hook for setting up default bridge networking."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
-DEPENDS = "go-cross"
-SRC_URI = "git://github.com/jfrazelle/netns;branch=master"
-SRCREV = "2804050eeab661bfa75c3aa06bdcf60273b02ca7"
+SRC_URI = "git://github.com/jessfraz/netns;branch=master"
+SRCREV = "85b1ab9fcccbaa404a2636b52a48bbde02437cf7"
PV = "0.1.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit go-osarchmap
+inherit goarch
+inherit go
do_compile() {
export GOARCH="${TARGET_GOARCH}"
-
+ export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
# Setup vendor directory so that it can be used in GOPATH.
#
# Go looks in a src directory under any directory in GOPATH but netns
@@ -23,8 +23,8 @@ do_compile() {
# We also need to link in the ipallocator directory as that is not under
# a src directory.
ln -sfn . "${S}/vendor/src"
- mkdir -p "${S}/vendor/src/github.com/jfrazelle/netns"
- ln -sfn "${S}/ipallocator" "${S}/vendor/src/github.com/jfrazelle/netns/ipallocator"
+ mkdir -p "${S}/vendor/src/github.com/jessfraz/netns"
+ ln -sfn "${S}/ipallocator" "${S}/vendor/src/github.com/jessfraz/netns/ipallocator"
export GOPATH="${S}/vendor"
# Pass the needed cflags/ldflags so that cgo