summaryrefslogtreecommitdiff
path: root/import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb47
1 files changed, 0 insertions, 47 deletions
diff --git a/import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb b/import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb
deleted file mode 100644
index d228a51c1..000000000
--- a/import-layers/yocto-poky/meta/recipes-core/systemd/systemd-compat-units.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "Enhances systemd compatilibity with existing SysVinit scripts"
-HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
-LICENSE = "MIT"
-
-PR = "r29"
-
-PACKAGE_WRITE_DEPS += "systemd-systemctl-native"
-
-S = "${WORKDIR}"
-
-inherit distro_features_check
-
-ALLOW_EMPTY_${PN} = "1"
-
-REQUIRED_DISTRO_FEATURES = "systemd"
-
-SYSTEMD_DISABLED_SYSV_SERVICES = " \
- busybox-udhcpc \
- hwclock \
- networking \
- nfsserver \
- nfscommon \
- syslog.busybox \
-"
-
-pkg_postinst_${PN} () {
-
- cd $D${sysconfdir}/init.d || exit 0
-
- echo "Disabling the following sysv scripts: "
-
- if [ -n "$D" ]; then
- OPTS="--root=$D"
- else
- OPTS=""
- fi
-
- for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
- if [ -e $i -o -e $i.sh ] && ! [ -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service ] ; then
- echo -n "$i: "
- systemctl $OPTS mask $i.service
- fi
- done
- echo
-}
-
-RDEPENDS_${PN} = "systemd"