summaryrefslogtreecommitdiff
path: root/import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb')
-rw-r--r--import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb74
1 files changed, 37 insertions, 37 deletions
diff --git a/import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb b/import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb
index ece0eab0f..cedf39eb6 100644
--- a/import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/import-layers/yocto-poky/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -15,6 +15,7 @@ RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_getopt} lsbinitscripts"
LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/lsb/lsb_release/1.4/lsb-release-1.4.tar.gz \
+ file://0001-fix-lsb_release-to-work-with-busybox-head-and-find.patch \
file://init-functions \
file://lsb_killproc \
file://lsb_log_message \
@@ -32,19 +33,18 @@ S = "${WORKDIR}/lsb-release-1.4"
CLEANBROKEN = "1"
-do_install(){
- oe_runmake install prefix=${D} mandir=${D}/${datadir}/man/ DESTDIR=${D}
+do_install() {
+ oe_runmake install prefix=${D}${base_prefix} mandir=${D}${datadir}/man/ DESTDIR=${D}
- # this 2 dirs are needed by package lsb-dist-checker
+ # these two dirs are needed by package lsb-dist-checker
mkdir -p ${D}${sysconfdir}/opt
mkdir -p ${D}${localstatedir}/opt
- mkdir -p ${D}${base_bindir}
- mkdir -p ${D}/${baselib}
+ mkdir -p ${D}${base_libdir}
mkdir -p ${D}${sysconfdir}/lsb-release.d
printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
else
printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
@@ -57,76 +57,76 @@ do_install(){
fi
echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
mkdir -p ${D}${sysconfdir}/lsb-release.d
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32
- elif [ "${TARGET_ARCH}" = "x86_64" ];then
+ elif [ "${TARGET_ARCH}" = "x86_64" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64
fi
- if [ "${TARGET_ARCH}" = "powerpc" ];then
+ if [ "${TARGET_ARCH}" = "powerpc" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32
- elif [ "${TARGET_ARCH}" = "powerpc64" ];then
+ elif [ "${TARGET_ARCH}" = "powerpc64" ]; then
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64
touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64
fi
}
-do_install_append(){
+do_install_append() {
install -d ${D}${sysconfdir}/core-lsb
for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon
do
- install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
+ install -m 0755 ${WORKDIR}/$i ${D}${sysconfdir}/core-lsb
done
- install -d ${D}/lib/lsb
- install -m 0755 ${WORKDIR}/init-functions ${D}/lib/lsb
+ install -d ${D}${nonarch_base_libdir}/lsb
+ install -m 0755 ${WORKDIR}/init-functions ${D}${nonarch_base_libdir}/lsb
- # creat links for LSB test
- install -d ${D}/usr/lib/lsb
- ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/install_initd
- ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/remove_initd
+ # create links for LSB test
+ if [ "${nonarch_base_libdir}" != "${nonarch_libdir}" ] ; then
+ install -d ${D}${nonarch_libdir}/lsb
+ fi
+ ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/install_initd
+ ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/remove_initd
- if [ "${TARGET_ARCH}" = "x86_64" ];then
- cd ${D}
- if [ "${baselib}" != "lib64" ]; then
- ln -sf ${baselib} lib64
+ if [ "${TARGET_ARCH}" = "x86_64" ]; then
+ if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+ lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
fi
- cd ${D}/${baselib}
+ cd ${D}${base_libdir}
ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
fi
- if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
- cd ${D}/${baselib}
+ if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then
+ cd ${D}${base_libdir}
ln -sf ld-linux.so.2 ld-lsb.so.2
ln -sf ld-linux.so.2 ld-lsb.so.3
fi
- if [ "${TARGET_ARCH}" = "powerpc64" ];then
- cd ${D}
- if [ "${baselib}" != "lib64" ]; then
- ln -sf ${baselib} lib64
+ if [ "${TARGET_ARCH}" = "powerpc64" ]; then
+ if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+ lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
fi
- cd ${D}/${baselib}
+ cd ${D}${base_libdir}
ln -sf ld64.so.1 ld-lsb-ppc64.so.2
ln -sf ld64.so.1 ld-lsb-ppc64.so.3
fi
- if [ "${TARGET_ARCH}" = "powerpc" ];then
- cd ${D}/${baselib}
+ if [ "${TARGET_ARCH}" = "powerpc" ]; then
+ cd ${D}${base_libdir}
ln -sf ld.so.1 ld-lsb-ppc32.so.2
ln -sf ld.so.1 ld-lsb-ppc32.so.3
fi
}
-FILES_${PN} += "/lib64 \
+
+FILES_${PN} += "${@'${base_prefix}/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${base_libdir}' != '${base_prefix}/lib64' else ''} \
${base_libdir} \
- /usr/lib/lsb \
- ${base_libdir}/lsb/* \
- /lib/lsb/* \
- "
+ ${nonarch_libdir}/lsb \
+ ${nonarch_base_libdir}/lsb/* \
+ "