summaryrefslogtreecommitdiff
path: root/meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend')
-rw-r--r--meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend b/meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend
new file mode 100644
index 000000000..18de4ac11
--- /dev/null
+++ b/meta-alibaba/meta-thor/recipes-bsp/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,17 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+KERNEL_VERSION_SANITY_SKIP="1"
+SRC_URI += "\
+ file://aspeed-alibaba-thor.dts \
+ file://alibaba.cfg \
+ "
+
+do_patch_append(){
+ for DTB in "${KERNEL_DEVICETREE}"; do
+ DT=`basename ${DTB} .dtb`
+ if [ -r "${WORKDIR}/${DT}.dts" ]; then
+ echo "debug: ${STAGING_KERNEL_DIR}"
+ cp ${WORKDIR}/aspeed-alibaba-thor.dts \
+ ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
+ fi
+ done
+}