summaryrefslogtreecommitdiff
path: root/meta-amd/meta-ethanolx
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd/meta-ethanolx')
-rw-r--r--meta-amd/meta-ethanolx/conf/bblayers.conf.sample2
-rw-r--r--meta-amd/meta-ethanolx/conf/layer.conf2
-rw-r--r--meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed/ethanolx.cfg1
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json280
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json77
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend10
-rw-r--r--meta-amd/meta-ethanolx/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend2
7 files changed, 372 insertions, 2 deletions
diff --git a/meta-amd/meta-ethanolx/conf/bblayers.conf.sample b/meta-amd/meta-ethanolx/conf/bblayers.conf.sample
index d84dbc759..2b8d624bc 100644
--- a/meta-amd/meta-ethanolx/conf/bblayers.conf.sample
+++ b/meta-amd/meta-ethanolx/conf/bblayers.conf.sample
@@ -11,6 +11,7 @@ BBLAYERS ?= " \
##OEROOT##/meta-openembedded/meta-networking \
##OEROOT##/meta-openembedded/meta-perl \
##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-security \
##OEROOT##/meta-phosphor \
##OEROOT##/meta-aspeed \
##OEROOT##/meta-amd \
@@ -22,6 +23,7 @@ BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta-openembedded/meta-networking \
##OEROOT##/meta-openembedded/meta-perl \
##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-security \
##OEROOT##/meta-phosphor \
##OEROOT##/meta-aspeed \
##OEROOT##/meta-amd \
diff --git a/meta-amd/meta-ethanolx/conf/layer.conf b/meta-amd/meta-ethanolx/conf/layer.conf
index 22fc7bed0..818ab7df1 100644
--- a/meta-amd/meta-ethanolx/conf/layer.conf
+++ b/meta-amd/meta-ethanolx/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "ethanolx-layer"
BBFILE_PATTERN_ethanolx-layer = "^${LAYERDIR}/"
BBFILE_PRIORITY_ethanolx-layer = "6"
-LAYERSERIES_COMPAT_ethanolx-layer = "dunfell gatesgarth"
+LAYERSERIES_COMPAT_ethanolx-layer = "gatesgarth hardknott"
diff --git a/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed/ethanolx.cfg b/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed/ethanolx.cfg
index 4a0a61e38..e20cd22d6 100644
--- a/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed/ethanolx.cfg
+++ b/meta-amd/meta-ethanolx/recipes-kernel/linux/linux-aspeed/ethanolx.cfg
@@ -1,2 +1,3 @@
CONFIG_SENSORS_LM75=y
+CONFIG_SENSORS_SBTSI=y
CONFIG_I2C_ASPEED=y
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json
new file mode 100644
index 000000000..0ce9f8096
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-baseboard.json
@@ -0,0 +1,280 @@
+{
+ "Exposes": [
+ {
+ "Name": "P0 Fan connector",
+ "Status": "disabled",
+ "Type": "FanConnector"
+ },
+ {
+ "Name": "P1 Fan connector",
+ "Status": "disabled",
+ "Type": "FanConnector"
+ },
+ {
+ "Address": "0x48",
+ "Bus": 7,
+ "Name": "BMC",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x49",
+ "Bus": 7,
+ "Name": "DIMM_P0_ABCD_P1_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4A",
+ "Bus": 7,
+ "Name": "DIMM_P1_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4B",
+ "Bus": 7,
+ "Name": "PCIe_Slots",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4C",
+ "Bus": 7,
+ "Name": "DIMM_P0_EFGH_P1_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4D",
+ "Bus": 7,
+ "Name": "DIMM_P1_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4E",
+ "Bus": 7,
+ "Name": "DIMM_P0_EFGH",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ },
+ {
+ "Address": "0x4F",
+ "Bus": 7,
+ "Name": "DIMM_P0_ABCD",
+ "Thresholds": [
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 40
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 38
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 5
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ }
+ ],
+ "Type": "LM75A"
+ }
+ ],
+ "Name": "AMD EthanolX Baseboard",
+ "Probe": "TRUE",
+ "Type": "Board",
+ "ProductId": "1",
+ "xyz.openbmc_project.Inventory.Decorator.Asset": {
+ "Manufacturer": "AMD",
+ "Model": "EthanolX",
+ "PartNumber": "109-H43111-00A_02",
+ "SerialNumber": "EX782B"
+ }
+}
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json
new file mode 100644
index 000000000..ff4cbdc54
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager/ethanolx-chassis.json
@@ -0,0 +1,77 @@
+{
+ "Exposes": [
+ {
+ "Index": 0,
+ "BindConnector": "P0 Fan connector",
+ "MaxReading": 6000,
+ "Name": "P0_Fan",
+ "Type": "AspeedFan",
+ "Pwm": 1,
+ "Tachs": [1],
+ "Thresholds": [
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 10
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 10000
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 8000
+ }
+ ]
+ },
+ {
+ "Index": 1,
+ "BindConnector": "P1 Fan connector",
+ "MaxReading": 6000,
+ "Name": "P1_Fan",
+ "Type": "AspeedFan",
+ "Pwm": 2,
+ "Tachs": [2],
+ "Thresholds": [
+ {
+ "Direction": "less than",
+ "Name": "lower critical",
+ "Severity": 1,
+ "Value": 0
+ },
+ {
+ "Direction": "less than",
+ "Name": "lower non critical",
+ "Severity": 0,
+ "Value": 10
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper critical",
+ "Severity": 1,
+ "Value": 10000
+ },
+ {
+ "Direction": "greater than",
+ "Name": "upper non critical",
+ "Severity": 0,
+ "Value": 8000
+ }
+ ]
+ }
+ ],
+ "Name": "AMD EthanolX Chassis",
+ "Probe": "FOUND('AMD EthanolX Baseboard')",
+ "Type": "Chassis"
+}
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 000000000..5a287694d
--- /dev/null
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append = " file://ethanolx-baseboard.json \
+ file://ethanolx-chassis.json"
+
+do_install_append() {
+ rm -f ${D}/usr/share/entity-manager/configurations/*.json
+ install -d ${D}/usr/share/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-baseboard.json ${D}/usr/share/entity-manager/configurations
+ install -m 0444 ${WORKDIR}/ethanolx-chassis.json ${D}/usr/share/entity-manager/configurations
+}
diff --git a/meta-amd/meta-ethanolx/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-amd/meta-ethanolx/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index fc565dc6e..b0631e627 100644
--- a/meta-amd/meta-ethanolx/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-amd/meta-ethanolx/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -1,5 +1,5 @@
FILESEXTRAPATHS_prepend_ethanolx := "${THISDIR}/${PN}:"
-EXTRA_OECONF_append_ethanolx = " --enable-negative-errno-on-fail"
+EXTRA_OEMESON_append_ethanolx = " -Dnegative-errno-on-fail=true"
CHIPS = " \