summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb b/meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb
new file mode 100644
index 000000000..d1dff35ec
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/network/ampere-usbnet.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Enable USB ethernet"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS += "systemd"
+RDEPENDS:${PN} += "libsystemd bash"
+
+inherit allarch systemd
+
+SRC_URI += "file://ampere-usbnet.service \
+ file://ampere_usbnet.sh \
+ file://00-bmc-usb0.network"
+
+do_install() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/ampere-usbnet.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sysconfdir_native}/systemd/network/
+ install -m 0644 ${WORKDIR}/00-bmc-usb0.network ${D}${sysconfdir_native}/systemd/network
+
+ install -d ${D}/${sbindir}
+ install -m 755 ${WORKDIR}/ampere_usbnet.sh ${D}/${sbindir}
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "ampere-usbnet.service"