summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
new file mode 100644
index 000000000..9b2840134
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
@@ -0,0 +1,23 @@
+
+SUMMARY = "Ampere Computing LLC Flashing Utilities"
+DESCRIPTION = "Application to support flashing utilities on Ampere platforms"
+PR = "r0"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+RDEPENDS_${PN} = "bash"
+DEPENDS = "zlib"
+
+SRC_URI += "\
+ file://ampere_flash_bios.sh \
+ "
+
+S = "${WORKDIR}"
+ROOT = "${STAGING_DIR_TARGET}"
+
+LDFLAGS += "-L ${ROOT}/usr/lib/ -lz "
+
+do_install_append() {
+ install -d ${D}/usr/sbin
+ install -m 0755 ${S}/ampere_flash_bios.sh ${D}/${sbindir}/ampere_flash_bios.sh
+}