summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb b/meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb
new file mode 100644
index 000000000..b6ddfad80
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-ampere/platform/ampere-mac-update.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Ampere Computing LLC Update MAC Address from FRU Inventory Information"
+DESCRIPTION = "Update MAC Address from FRU Inventory Information for Ampere systems"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+inherit obmc-phosphor-systemd
+
+DEPENDS = "systemd"
+RDEPENDS:${PN} = "bash"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://ampere_update_mac.sh \
+ "
+
+SYSTEMD_SERVICE:${PN} = "ampere_update_mac.service"
+
+do_install:append() {
+ install -d ${D}/${sbindir}
+ install -m 755 ${WORKDIR}/ampere_update_mac.sh ${D}/${sbindir}
+}