summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/README.md45
-rw-r--r--meta-aspeed/conf/machine/include/aspeed.inc2
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb4
3 files changed, 39 insertions, 12 deletions
diff --git a/meta-aspeed/README.md b/meta-aspeed/README.md
index 6c3221ef9..b97bbc78d 100644
--- a/meta-aspeed/README.md
+++ b/meta-aspeed/README.md
@@ -1,9 +1,36 @@
-ASPEED
-================
-
-This is the ASPEED Board Support Package (BSP) layer. It supports the
-AST2400 and AST2500; ARM service management SOCs made by ASPEED. More
-information about the AST2400 and AST2500 can be found
-[here](https://www.aspeedtech.com/products.php?fPath=20&rId=376)
-and
-[here](https://www.aspeedtech.com/products.php?fPath=20&rId=440).
+OpenEmbedded/Yocto BSP layer for Aspeed's platforms
+======================================================================
+
+This layer provides support for Aspeed's platforms for use with OpenEmbedded
+and/or Yocto.
+
+```
+This layer depends on:
+
+URI: git://git.openembedded.org/openembedded-core
+layers: meta
+branch: master
+revision: HEAD
+```
+
+Contributing
+------------
+
+meta-aspeed patches are reviewed using the Gerrit instance at
+https://gerrit.openbmc-project.xyz.
+
+Please submit patches to Gerrit. More information on using Gerrit can be found
+[here](https://github.com/openbmc/docs/blob/master/CONTRIBUTING.md#submitting-changes-via-gerrit-server).
+https://github.com/openbmc/meta-aspeed is a hosting mirror only and GitHub
+pull requests are not monitored and will not be accepted.
+
+Patch checklist. Please ensure patches adhere to the following guidelines:
+
+ - meta-aspeed uses the [OE style
+ guidelines](https://www.openembedded.org/wiki/Styleguide).
+ - follow [the seven rules of a great git commit
+ message](https://chris.beams.io/posts/git-commit/#seven-rules)
+
+For questions or help please come join us on the [mailing
+list](https://lists.ozlabs.org/listinfo/openbmc) or in
+[IRC](irc://freenode.net/openbmc).
diff --git a/meta-aspeed/conf/machine/include/aspeed.inc b/meta-aspeed/conf/machine/include/aspeed.inc
index 946eebccd..05e465849 100644
--- a/meta-aspeed/conf/machine/include/aspeed.inc
+++ b/meta-aspeed/conf/machine/include/aspeed.inc
@@ -13,7 +13,7 @@ KERNEL_CLASSES ?= "kernel-fitimage"
INITRAMFS_IMAGE ?= "aspeed-image-initramfs"
INITRAMFS_FSTYPES ?= "cpio.xz"
-MACHINE_EXTRA_RRECOMMENDS += "udev-aspeed-vuart"
+MACHINE_EXTRA_RRECOMMENDS += "udev-aspeed-vuart udev-aspeed-mtd-partitions"
MACHINEOVERRIDES =. "aspeed:"
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index da191586e..43800a178 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-5.3"
-LINUX_VERSION ?= "5.3.6"
+LINUX_VERSION ?= "5.3.7"
-SRCREV="62d45cc8d76110a9e8e9107ff91420e89ef01681"
+SRCREV="b172fa10db70d01b3f9626209decd8b10e6aafd0"
require linux-aspeed.inc