summaryrefslogtreecommitdiff
path: root/meta-bytedance/meta-g220a
diff options
context:
space:
mode:
Diffstat (limited to 'meta-bytedance/meta-g220a')
-rw-r--r--meta-bytedance/meta-g220a/conf/local.conf.sample2
-rw-r--r--meta-bytedance/meta-g220a/conf/machine/g220a.conf10
-rw-r--r--meta-bytedance/meta-g220a/recipes-kernel/linux/linux-aspeed/0003-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch24
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json6
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend10
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy/0001-Remove-Total_Power-sensor.patch35
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb23
7 files changed, 88 insertions, 22 deletions
diff --git a/meta-bytedance/meta-g220a/conf/local.conf.sample b/meta-bytedance/meta-g220a/conf/local.conf.sample
index 0ebc07e45..207786200 100644
--- a/meta-bytedance/meta-g220a/conf/local.conf.sample
+++ b/meta-bytedance/meta-g220a/conf/local.conf.sample
@@ -3,7 +3,7 @@ DISTRO ?= "openbmc-phosphor"
PACKAGE_CLASSES ?= "package_rpm"
SANITY_TESTED_DISTROS_append ?= " *"
EXTRA_IMAGE_FEATURES = "debug-tweaks"
-USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+USER_CLASSES ?= "buildstats image-prelink"
PATCHRESOLVE = "noop"
BB_DISKMON_DIRS = "\
STOPTASKS,${TMPDIR},1G,100K \
diff --git a/meta-bytedance/meta-g220a/conf/machine/g220a.conf b/meta-bytedance/meta-g220a/conf/machine/g220a.conf
index 692c9f664..ba7a253e3 100644
--- a/meta-bytedance/meta-g220a/conf/machine/g220a.conf
+++ b/meta-bytedance/meta-g220a/conf/machine/g220a.conf
@@ -1,12 +1,10 @@
KMACHINE = "aspeed"
KERNEL_DEVICETREE = "${KMACHINE}-bmc-bytedance-${MACHINE}.dtb"
-UBOOT_MACHINE = "ast_g5_ncsi_config"
+UBOOT_MACHINE = "evb-ast2500_defconfig"
+UBOOT_DEVICETREE = "ast2500-evb"
FLASH_SIZE = "65536"
-FLASH_UBOOT_OFFSET = "0"
-FLASH_ROFS_OFFSET = "5632"
-FLASH_RWFS_OFFSET = "49152"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
@@ -33,3 +31,7 @@ PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-bytedance-apps"
PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-bytedance-apps"
PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw ?= "phosphor-ipmi-kcs"
PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-bytedance-apps"
+
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot = "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils = "u-boot-fw-utils-aspeed-sdk"
diff --git a/meta-bytedance/meta-g220a/recipes-kernel/linux/linux-aspeed/0003-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch b/meta-bytedance/meta-g220a/recipes-kernel/linux/linux-aspeed/0003-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch
index 7076ede20..317f94b05 100644
--- a/meta-bytedance/meta-g220a/recipes-kernel/linux/linux-aspeed/0003-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch
+++ b/meta-bytedance/meta-g220a/recipes-kernel/linux/linux-aspeed/0003-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch
@@ -1,7 +1,7 @@
-From dc37d698586a7ca4e4381ef7726249fa70d14c89 Mon Sep 17 00:00:00 2001
+From e0769dda0adcabc41d322726b16148e3960473c1 Mon Sep 17 00:00:00 2001
From: Oskar Senft <osk@google.com>
Date: Wed, 8 Aug 2018 10:15:05 -0400
-Subject: [PATCH 3/5] misc: aspeed: Add Aspeed UART routing control driver.
+Subject: [PATCH] misc: aspeed: Add Aspeed UART routing control driver.
This driver adds sysfs files that allow the BMC userspace to configure
how UARTs and physical serial I/O ports are routed.
@@ -102,12 +102,12 @@ index 000000000000..cf1c2a466875
+$ cat /sys/bus/platform/drivers/aspeed-uart-routing/*.uart_routing/uart1
+io1 io2 io3 io4 uart2 [uart3] uart4 io6
diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
-index d8626a0d3e31..48a519c59bdf 100644
+index 54cfb599cd3e..9d2d95ab313a 100644
--- a/drivers/misc/Kconfig
+++ b/drivers/misc/Kconfig
-@@ -451,6 +451,12 @@ config MCTP_LPC
- Implements the MCTP LPC binding via KCS LPC IO cycles for control and
- LPC FWH cycles for data
+@@ -487,6 +487,12 @@ config NPCM7XX_JTAG_MASTER
+ help
+ Control PSPI/GPIO to transmit jtag signals to support jtag master function.
+config ASPEED_UART_ROUTING
+ tristate "Aspeed ast2500 UART routing control"
@@ -115,17 +115,17 @@ index d8626a0d3e31..48a519c59bdf 100644
+ If you want to configure UART routing on Aspeed BMC platforms, enable
+ this option.
+
- config MISC_RTSX
- tristate
- default MISC_RTSX_PCI || MISC_RTSX_USB
+ source "drivers/misc/c2port/Kconfig"
+ source "drivers/misc/eeprom/Kconfig"
+ source "drivers/misc/cb710/Kconfig"
diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
-index 183970192ced..4e67e21c2e65 100644
+index 39e5ba5d0985..77e95db728da 100644
--- a/drivers/misc/Makefile
+++ b/drivers/misc/Makefile
-@@ -60,3 +60,4 @@ obj-$(CONFIG_XILINX_SDFEC) += xilinx_sdfec.o
+@@ -60,3 +60,4 @@ obj-$(CONFIG_HISI_HIKEY_USB) += hisi_hikey_usb.o
obj-$(CONFIG_NPCM7XX_LPC_BPC) += npcm7xx-lpc-bpc.o
obj-$(CONFIG_NPCM7XX_PCI_MBOX) += npcm7xx-pci-mbox.o
- obj-$(CONFIG_MCTP_LPC) += mctp-lpc.o
+ obj-$(CONFIG_NPCM7XX_JTAG_MASTER) += npcm7xx-jtag-master.o
+obj-$(CONFIG_ASPEED_UART_ROUTING) += aspeed-uart-routing.o
diff --git a/drivers/misc/aspeed-uart-routing.c b/drivers/misc/aspeed-uart-routing.c
new file mode 100644
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json b/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
index ae008da53..03a5d2aa3 100644
--- a/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
@@ -908,6 +908,10 @@
"Name": "Host/BMC Shared NIC",
"Type": "NIC"
},
+ {
+ "Name": "Node Manager Sensor",
+ "Type": "NMSensor"
+ },
{
"Address": "0x70",
"Bus": 3,
@@ -2516,4 +2520,4 @@
"AssetTag": "$PRODUCT_ASSET_TAG"
},
"xyz.openbmc_project.Inventory.Item.System": {}
-} \ No newline at end of file
+}
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
index e38c2721b..3059e809a 100644
--- a/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1,4 +1,6 @@
-OBMC_IMAGE_EXTRA_INSTALL_append_g220a = " webui-vue \
- me-time-sync \
- static-mac-addr \
- "
+OBMC_IMAGE_EXTRA_INSTALL_append_g220a = " \
+ webui-vue \
+ me-time-sync \
+ static-mac-addr \
+ phosphor-node-manager-proxy \
+"
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy/0001-Remove-Total_Power-sensor.patch b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy/0001-Remove-Total_Power-sensor.patch
new file mode 100644
index 000000000..837982da2
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy/0001-Remove-Total_Power-sensor.patch
@@ -0,0 +1,35 @@
+From 086b098ea4160963cd09405fbdf6816bef095d16 Mon Sep 17 00:00:00 2001
+From: Lei YU <yulei.sh@bytedance.com>
+Date: Tue, 15 Dec 2020 16:50:31 +0800
+Subject: [PATCH] Remove Total_Power sensor
+
+The Total_Power sensor is not used on g220a system. Remove it.
+The sensor will be replaced by a virtual sensor.
+
+Tested: Verify the Total_Power sensor is gone on DBus.
+
+Signed-off-by: Lei YU <yulei.sh@bytedance.com>
+---
+ NodeManagerProxy.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/NodeManagerProxy.cpp b/NodeManagerProxy.cpp
+index d9fb760..9dbd5da 100644
+--- a/NodeManagerProxy.cpp
++++ b/NodeManagerProxy.cpp
+@@ -120,9 +120,9 @@ void createSensors()
+ // NM Statistics
+ // Global power statistics
+ configuredSensors.push_back(std::make_unique<PowerMetric>(server));
+- configuredSensors.push_back(std::make_unique<GlobalPowerPlatform>(
+- server, 0, 2040, "power", "Total_Power", globalPowerStats,
+- entirePlatform, 0));
++// configuredSensors.push_back(std::make_unique<GlobalPowerPlatform>(
++// server, 0, 2040, "power", "Total_Power", globalPowerStats,
++// entirePlatform, 0));
+ configuredSensors.push_back(
+ std::make_unique<GlobalPowerCpu>(server, 0, 510, "power", "CPU_Power",
+ globalPowerStats, cpuSubsystem, 0));
+--
+2.25.1
+
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb
new file mode 100644
index 000000000..1fa04843f
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Node Manager Proxy"
+DESCRIPTION = "The Node Manager Proxy provides a simple interface for communicating \
+with Management Engine via IPMB"
+
+SRC_URI = "git://github.com/Intel-BMC/node-manager;protocol=ssh"
+SRCREV = "23590b428ea26e0ed4b8225015471b962e3b3704"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SYSTEMD_SERVICE_${PN} = "node-manager-proxy.service"
+
+DEPENDS = "sdbusplus \
+ phosphor-logging \
+ boost"
+
+S = "${WORKDIR}/git/"
+inherit cmake systemd
+
+SRC_URI_append = " \
+ file://0001-Remove-Total_Power-sensor.patch \
+"