summaryrefslogtreecommitdiff
path: root/meta-bytedance
diff options
context:
space:
mode:
Diffstat (limited to 'meta-bytedance')
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service14
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control_%.bbappend5
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service b/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service
new file mode 100644
index 000000000..659ff3e1e
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control/phosphor-pid-control.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Phosphor-Pid-Control Margin-based Fan Control Daemon
+After=xyz.openbmc_project.EntityManager.service
+After=xyz.openbmc_project.ObjectMapper.service
+
+[Service]
+Restart=always
+ExecStart={bindir}/swampd -t
+RestartSec=5
+StartLimitInterval=0
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
new file mode 100644
index 000000000..66646996c
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+inherit obmc-phosphor-systemd
+
+SYSTEMD_SERVICE_${PN} = "phosphor-pid-control.service"