summaryrefslogtreecommitdiff
path: root/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds
diff options
context:
space:
mode:
Diffstat (limited to 'meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds')
-rw-r--r--meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb17
-rw-r--r--meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml37
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb
new file mode 100644
index 000000000..01b58da39
--- /dev/null
+++ b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Phosphor LED Group Management for Enclustra Mars ZX3"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml
new file mode 100644
index 000000000..38eb7697f
--- /dev/null
+++ b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml
@@ -0,0 +1,37 @@
+enclosure_identify:
+ led1:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 100
+
+bmc_booted:
+ led2:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+power_on:
+ led3:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+enclosure_fault:
+ led3:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 30
+
+lamp_test:
+ led1:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 50
+ led2:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 100
+ led3:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 150