summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-tiogapass
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-tiogapass')
-rw-r--r--meta-facebook/meta-tiogapass/conf/bblayers.conf.sample2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch39
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed/tiogapass.cfg12
5 files changed, 55 insertions, 2 deletions
diff --git a/meta-facebook/meta-tiogapass/conf/bblayers.conf.sample b/meta-facebook/meta-tiogapass/conf/bblayers.conf.sample
index f0ae07c32..a452dd666 100644
--- a/meta-facebook/meta-tiogapass/conf/bblayers.conf.sample
+++ b/meta-facebook/meta-tiogapass/conf/bblayers.conf.sample
@@ -15,7 +15,6 @@ BBLAYERS ?= " \
##OEROOT##/meta-openembedded/meta-webserver \
##OEROOT##/meta-phosphor \
##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openpower \
##OEROOT##/meta-facebook \
##OEROOT##/meta-facebook/meta-tiogapass \
"
@@ -29,7 +28,6 @@ BBLAYERS_NON_REMOVABLE ?= " \
##OEROOT##/meta-openembedded/meta-webserver \
##OEROOT##/meta-phosphor \
##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openpower \
##OEROOT##/meta-facebook \
##OEROOT##/meta-facebook/meta-tiogapass \
"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
new file mode 100644
index 000000000..4bec6c8d5
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
@@ -0,0 +1,39 @@
+From 44cdd36855728059e58dcad52b42d825bb1cc2af Mon Sep 17 00:00:00 2001
+From: Paul Fertser <fercerpav@gmail.com>
+Date: Fri, 25 Sep 2020 18:36:45 +0300
+Subject: [PATCH] configs/ast-common: use 57600 baud rate to match Tioga Pass
+ EFI firmware
+
+This is a Tioga Pass specific patch, only for
+meta-facebook/meta-tiogapass layer.
+
+Signed-off-by: Paul Fertser <fercerpav@gmail.com>
+---
+ include/configs/ast-common.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/configs/ast-common.h b/include/configs/ast-common.h
+index a0243083bd..f0f2ae08b6 100644
+--- a/include/configs/ast-common.h
++++ b/include/configs/ast-common.h
+@@ -56,7 +56,7 @@
+ #define CONFIG_SYS_LOADS_BAUD_CHANGE
+ #define CONFIG_SERIAL1 1
+ #define CONFIG_CONS_INDEX 1
+-#define CONFIG_BAUDRATE 115200
++#define CONFIG_BAUDRATE 57600
+
+ /*
+ * BOOTP options
+@@ -96,7 +96,7 @@
+ #define CONFIG_CMD_MTDPARTS
+ #endif
+
+-#define CONFIG_BOOTARGS "console=ttyS4,115200n8 root=/dev/ram rw"
++#define CONFIG_BOOTARGS "console=ttyS4,57600n8 root=/dev/ram rw"
+
+ #define CONFIG_AST_SPI_NOR /* AST SPI NOR Flash */
+ #define CONFIG_FMC_CS 1
+--
+2.17.1
+
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
new file mode 100644
index 000000000..b9bf0af2a
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
new file mode 100644
index 000000000..f24fe5e4f
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-aspeed:"
+SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed/tiogapass.cfg b/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed/tiogapass.cfg
index 7ea8dc31a..7fd89e2a2 100644
--- a/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed/tiogapass.cfg
+++ b/meta-facebook/meta-tiogapass/recipes-kernel/linux/linux-aspeed/tiogapass.cfg
@@ -4,3 +4,15 @@ CONFIG_RTC_DRV_RV8803=y
CONFIG_TCG_TPM=y
CONFIG_TCG_TIS_I2C_INFINEON=y
CONFIG_NCSI_OEM_CMD_GET_MAC=y
+CONFIG_IPV6_SIT=n
+CONFIG_I2C_SLAVE=y
+CONFIG_SENSORS_PXE1610=y
+CONFIG_SENSORS_INA2XX=y
+CONFIG_SOC_ASPEED=y
+CONFIG_IPMB_DEVICE_INTERFACE=y
+CONFIG_PECI=y
+CONFIG_PECI_CHARDEV=y
+CONFIG_PECI_ASPEED=y
+CONFIG_SENSORS_PECI_DIMMTEMP=y
+CONFIG_SENSORS_PECI_CPUTEMP=y
+CONFIG_MFD_INTEL_PECI_CLIENT=y