summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb')
-rwxr-xr-xmeta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
new file mode 100755
index 000000000..77d1e4570
--- /dev/null
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Facebook OEM IPMI commands"
+DESCRIPTION = "Facebook OEM IPMI commands"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
+
+SRC_URI = "git://github.com/openbmc/fb-ipmi-oem"
+SRCREV = "317999d3ac917654950e1288171b0cd546754880"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd "
+
+inherit cmake obmc-phosphor-ipmiprovider-symlink
+
+EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+
+LIBRARY_NAMES = "libzfboemcmds.so"
+
+HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
+
+FILES_${PN}_append = " ${datadir}/lcd-debug/post_desc.json"
+FILES_${PN}_append = " ${datadir}/lcd-debug/gpio_desc.json"
+FILES_${PN}_append = " ${datadir}/lcd-debug/cri_sensors.json"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
+
+do_install_append(){
+ install -d ${D}${includedir}/fb-ipmi-oem
+ install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/fb-ipmi-oem
+}