summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook')
-rwxr-xr-xmeta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb4
-rw-r--r--meta-facebook/recipes-phosphor/settings/phosphor-settings-manager/yosemitev2/settings-manager.override.yml39
-rw-r--r--meta-facebook/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend2
3 files changed, 44 insertions, 1 deletions
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
index 03db6c329..6cc2450c5 100755
--- a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
SRC_URI = "git://github.com/openbmc/fb-ipmi-oem"
-SRCREV = "5f8e343516c0db488e977084ca7810a6c9fafae8"
+SRCREV = "c723d6a5917cde0808713bc57934eb503fa20b8a"
S = "${WORKDIR}/git"
PV = "0.1+git${SRCPV}"
@@ -17,6 +17,8 @@ inherit cmake obmc-phosphor-ipmiprovider-symlink
EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
EXTRA_OECMAKE_append_yosemitev2 = " -DBIC=1"
+EXTRA_OECMAKE_append = " -DHOST_INSTANCES='${OBMC_HOST_INSTANCES}'"
+
LIBRARY_NAMES = "libzfboemcmds.so"
HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
diff --git a/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager/yosemitev2/settings-manager.override.yml b/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager/yosemitev2/settings-manager.override.yml
new file mode 100644
index 000000000..3fdc847c7
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager/yosemitev2/settings-manager.override.yml
@@ -0,0 +1,39 @@
+/xyz/openbmc_project/control/host1/boot:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
+
+/xyz/openbmc_project/control/host2/boot:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
+
+/xyz/openbmc_project/control/host3/boot:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
+
+/xyz/openbmc_project/control/host4/boot:
+ - Interface: xyz.openbmc_project.Control.Boot.Source
+ Properties:
+ BootSource:
+ Default: Source::Sources::Default
+ - Interface: xyz.openbmc_project.Control.Boot.Mode
+ Properties:
+ BootMode:
+ Default: Mode::Modes::Regular
diff --git a/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
new file mode 100644
index 000000000..2b4c4c0cb
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append_yosemitev2 = " file://settings-manager.override.yml"