summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/conf/machine/include/facebook-compute.inc2
-rw-r--r--meta-facebook/conf/machine/include/facebook-nohost.inc3
-rw-r--r--meta-facebook/conf/machine/include/facebook-withhost.inc15
-rw-r--r--meta-facebook/conf/machine/include/facebook.inc7
-rw-r--r--meta-facebook/meta-bletchley/conf/bblayers.conf.sample35
-rw-r--r--meta-facebook/meta-bletchley/conf/conf-notes.txt2
-rw-r--r--meta-facebook/meta-bletchley/conf/layer.conf11
-rw-r--r--meta-facebook/meta-bletchley/conf/local.conf.sample223
-rw-r--r--meta-facebook/meta-bletchley/conf/machine/bletchley.conf15
-rw-r--r--meta-facebook/meta-tiogapass/conf/local.conf.sample3
-rw-r--r--meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog/rsyslog.conf17
-rw-r--r--meta-facebook/meta-yosemitev2/conf/local.conf.sample3
-rw-r--r--meta-facebook/recipes-fb/packagegroups/packagegroup-fb-apps.bb18
-rw-r--r--meta-facebook/recipes-phosphor/images/obmc-phosphor-image.bbappend3
-rw-r--r--meta-facebook/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend5
-rw-r--r--meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor/bletchley/bletchley_sensor_config.json1
16 files changed, 345 insertions, 18 deletions
diff --git a/meta-facebook/conf/machine/include/facebook-compute.inc b/meta-facebook/conf/machine/include/facebook-compute.inc
index 66b0f756b..7d61f81e1 100644
--- a/meta-facebook/conf/machine/include/facebook-compute.inc
+++ b/meta-facebook/conf/machine/include/facebook-compute.inc
@@ -1,3 +1,3 @@
-require conf/machine/include/facebook.inc
+require conf/machine/include/facebook-withhost.inc
OVERRIDES .= ":fb-compute"
diff --git a/meta-facebook/conf/machine/include/facebook-nohost.inc b/meta-facebook/conf/machine/include/facebook-nohost.inc
new file mode 100644
index 000000000..e9af8e94d
--- /dev/null
+++ b/meta-facebook/conf/machine/include/facebook-nohost.inc
@@ -0,0 +1,3 @@
+require conf/machine/include/facebook.inc
+
+OVERRIDES .= ":fb-nohost"
diff --git a/meta-facebook/conf/machine/include/facebook-withhost.inc b/meta-facebook/conf/machine/include/facebook-withhost.inc
new file mode 100644
index 000000000..ebe79d1a4
--- /dev/null
+++ b/meta-facebook/conf/machine/include/facebook-withhost.inc
@@ -0,0 +1,15 @@
+require conf/machine/include/facebook.inc
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-chassis-state-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ "
+
+VIRTUAL-RUNTIME_obmc-host-state-manager ?= "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager ?= "x86-power-control"
+
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw ?= "phosphor-ipmi-kcs"
+
+OVERRIDES .= ":fb-withhost"
diff --git a/meta-facebook/conf/machine/include/facebook.inc b/meta-facebook/conf/machine/include/facebook.inc
index 9c9490bda..2993dc438 100644
--- a/meta-facebook/conf/machine/include/facebook.inc
+++ b/meta-facebook/conf/machine/include/facebook.inc
@@ -1,21 +1,14 @@
OBMC_MACHINE_FEATURES += "\
obmc-bmc-state-mgmt \
- obmc-chassis-state-mgmt \
- obmc-host-ipmi \
- obmc-host-state-mgmt \
- obmc-phosphor-chassis-mgmt \
obmc-phosphor-fan-mgmt \
obmc-phosphor-flash-mgmt \
"
VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
-VIRTUAL-RUNTIME_obmc-host-state-manager ?= "x86-power-control"
-VIRTUAL-RUNTIME_obmc-chassis-state-manager ?= "x86-power-control"
PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-fb-apps"
PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-fb-apps"
PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-fb-apps"
-PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw ?= "phosphor-ipmi-kcs"
PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-fb-apps"
diff --git a/meta-facebook/meta-bletchley/conf/bblayers.conf.sample b/meta-facebook/meta-bletchley/conf/bblayers.conf.sample
new file mode 100644
index 000000000..e02b182c7
--- /dev/null
+++ b/meta-facebook/meta-bletchley/conf/bblayers.conf.sample
@@ -0,0 +1,35 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-poky \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-perl \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-openembedded/meta-webserver \
+ ##OEROOT##/meta-security \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-facebook \
+ ##OEROOT##/meta-facebook/meta-bletchley \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-poky \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-perl \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-openembedded/meta-webserver \
+ ##OEROOT##/meta-security \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-facebook \
+ ##OEROOT##/meta-facebook/meta-bletchley \
+ "
diff --git a/meta-facebook/meta-bletchley/conf/conf-notes.txt b/meta-facebook/meta-bletchley/conf/conf-notes.txt
new file mode 100644
index 000000000..9b3c01a55
--- /dev/null
+++ b/meta-facebook/meta-bletchley/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common targets are:
+ obmc-phosphor-image
diff --git a/meta-facebook/meta-bletchley/conf/layer.conf b/meta-facebook/meta-bletchley/conf/layer.conf
new file mode 100644
index 000000000..505e67c68
--- /dev/null
+++ b/meta-facebook/meta-bletchley/conf/layer.conf
@@ -0,0 +1,11 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "bletchley-layer"
+BBFILE_PATTERN_bletchley-layer := "^${LAYERDIR}/"
+
+LAYERSERIES_COMPAT_bletchley-layer := "gatesgarth hardknott"
diff --git a/meta-facebook/meta-bletchley/conf/local.conf.sample b/meta-facebook/meta-bletchley/conf/local.conf.sample
new file mode 100644
index 000000000..bb86f3418
--- /dev/null
+++ b/meta-facebook/meta-bletchley/conf/local.conf.sample
@@ -0,0 +1,223 @@
+#
+# This file is your local configuration file and is where all local user settings
+# are placed. The comments in this file give some guide to the options a new user
+# to the system might want to change but pretty much any configuration option can
+# be set in this file.
+#
+# Lines starting with the '#' character are commented out and in some cases the
+# default values are provided as comments to show people example syntax. Enabling
+# the option is a question of removing the # character and making any change to the
+# variable as required.
+
+#
+# Machine Selection
+#
+MACHINE ??= "bletchley"
+
+#
+# Where to place downloads
+#
+# During a first build the system will download many different source code tarballs
+# from various upstream projects. This can take a while, particularly if your network
+# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
+# can preserve this directory to speed up this part of subsequent builds. This directory
+# is safe to share between multiple builds on the same machine too.
+#
+# The default is a downloads directory under TOPDIR which is the build directory.
+#
+#DL_DIR ?= "${TOPDIR}/downloads"
+
+#
+# Where to place shared-state files
+#
+# BitBake has the capability to accelerate builds based on previously built output.
+# This is done using "shared state" files which can be thought of as cache objects
+# and this option determines where those files are placed.
+#
+# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
+# from these files if no changes were made to the configuration. If changes were made
+# to the configuration, only shared state files where the state was still valid would
+# be used (done using checksums).
+#
+# The default is a sstate-cache directory under TOPDIR.
+#
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+#
+# Where to place the build output
+#
+# This option specifies where the bulk of the building work should be done and
+# where BitBake should place its temporary files and output. Keep in mind that
+# this includes the extraction and compilation of many applications and the toolchain
+# which can use Gigabytes of hard disk space.
+#
+# The default is a tmp directory under TOPDIR.
+#
+#TMPDIR = "${TOPDIR}/tmp"
+
+#
+# Default policy config
+#
+# The distribution setting controls which policy settings are used as defaults.
+# The default value is fine for general Yocto project use, at least initially.
+# Ultimately when creating custom policy, people will likely end up subclassing
+# these defaults.
+#
+DISTRO ?= "openbmc-phosphor"
+# As an example of a subclass there is a "bleeding" edge policy configuration
+# where many versions are set to the absolute latest code from the upstream
+# source control systems. This is just mentioned here as an example, its not
+# useful to most new users.
+# DISTRO ?= "poky-bleeding"
+
+#
+# Package Management configuration
+#
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
+# to generate the root filesystems.
+# Options are:
+# - 'package_deb' for debian style deb files
+# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
+# - 'package_rpm' for rpm style packages
+# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+# We default to rpm:
+PACKAGE_CLASSES ?= "package_rpm"
+
+#
+# SDK/ADT target architecture
+#
+# This variable specifies the architecture to build SDK/ADT items for and means
+# you can build the SDK packages for architectures other than the machine you are
+# running the build on (i.e. building i686 packages on an x86_64 host).
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+SANITY_TESTED_DISTROS_append ?= " *"
+
+#
+# Extra image configuration defaults
+#
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# images. Some of these options are added to certain image types automatically. The
+# variable can contain the following options:
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
+# (useful if you want to run the package test suites)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "eclipse-debug" - add Eclipse remote debugging support
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image suitable for development
+# e.g. ssh root access has a blank password
+# There are other application targets that can be used here too, see
+# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
+# We default to enabling the debugging tweaks.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+
+#
+# Additional image features
+#
+# The following is a list of additional classes to use when building images which
+# enable extra features. Some available options which can be included in this variable
+# are:
+# - 'buildstats' collect build statistics
+# - 'image-mklibs' to reduce shared library files size for an image
+# - 'image-prelink' in order to prelink the filesystem image
+# - 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+
+#
+# Runtime testing of images
+#
+# The build system can test booting virtual machine images under qemu (an emulator)
+# after any root filesystems are created and run tests against those images. To
+# enable this uncomment this line. See classes/testimage(-auto).bbclass for
+# further details.
+#TEST_IMAGE = "1"
+#
+# Interactive shell configuration
+#
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
+# multithreaded and needs to be able to handle the case where more than one parallel
+# process may require the user's attention. The default is iterate over the available
+# terminal types to find one that works.
+#
+# Examples of the occasions this may happen are when resolving patches which cannot
+# be applied, to use the devshell or the kernel menuconfig
+#
+# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
+# Note: currently, Konsole support only works for KDE 3.x due to the way
+# newer Konsole versions behave
+#OE_TERMINAL = "auto"
+# By default disable interactive patch resolution (tasks will just fail instead):
+PATCHRESOLVE = "noop"
+
+#
+# Disk Space Monitoring during the build
+#
+# Monitor the disk space during the build. If there is less that 1GB of space or less
+# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# of the build. The reason for this is that running completely out of space can corrupt
+# files and damages the build in ways which may not be easily recoverable.
+# It's necessary to monitor /tmp, if there is no space left the build will fail
+# with very exotic errors.
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K \
+ ABORT,/tmp,10M,1K"
+
+#
+# Shared-state files from other locations
+#
+# As mentioned above, shared state files are prebuilt cache data objects which can
+# used to accelerate build time. This variable can be used to configure the system
+# to search other mirror locations for these objects before it builds the data itself.
+#
+# This can be a filesystem directory, or a remote url such as http or ftp. These
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# cache locations to check for the shared objects.
+# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
+# at the end as shown in the examples below. This will be substituted with the
+# correct path within the directory structure.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
+#file://.* file:///some/local/dir/sstate/PATH"
+
+
+#
+# Qemu configuration
+#
+# By default qemu will build with a builtin VNC server where graphical output can be
+# seen. The two lines below enable the SDL backend too. This assumes there is a
+# libsdl library available on your build system.
+#PACKAGECONFIG_append_pn-qemu-native = " sdl"
+#PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+#ASSUME_PROVIDED += "libsdl-native"
+
+
+# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
+# track the version of this file when it was generated. This can safely be ignored if
+# this doesn't mean anything to you.
+CONF_VERSION = "1"
+
+# Set the root password to '0penBmc'
+INHERIT += "extrausers"
+
+EXTRA_USERS_PARAMS = " \
+ usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root; \
+ "
diff --git a/meta-facebook/meta-bletchley/conf/machine/bletchley.conf b/meta-facebook/meta-bletchley/conf/machine/bletchley.conf
new file mode 100644
index 000000000..8de7a54d2
--- /dev/null
+++ b/meta-facebook/meta-bletchley/conf/machine/bletchley.conf
@@ -0,0 +1,15 @@
+#KMACHINE = "aspeed"
+#KERNEL_DEVICETREE = "${KMACHINE}-bmc-facebook-${MACHINE}.dtb"
+KERNEL_DEVICETREE = "aspeed-ast2600-evb.dtb"
+
+UBOOT_MACHINE = "ast2600_openbmc_spl_defconfig"
+UBOOT_DEVICETREE = "ast2600a1-evb"
+SPL_BINARY = "spl/u-boot-spl.bin"
+
+require conf/machine/include/facebook-nohost.inc
+require conf/machine/include/ast2600.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+SERIAL_CONSOLES = "57600;ttyS4"
+
+FLASH_SIZE = "131072"
diff --git a/meta-facebook/meta-tiogapass/conf/local.conf.sample b/meta-facebook/meta-tiogapass/conf/local.conf.sample
index a575746c5..641963aed 100644
--- a/meta-facebook/meta-tiogapass/conf/local.conf.sample
+++ b/meta-facebook/meta-tiogapass/conf/local.conf.sample
@@ -126,12 +126,11 @@ EXTRA_IMAGE_FEATURES = "debug-tweaks"
# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-mklibs' to reduce shared library files size for an image
# - 'image-prelink' in order to prelink the filesystem image
# - 'image-swab' to perform host system intrusion detection
# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+USER_CLASSES ?= "buildstats image-prelink"
#
# Runtime testing of images
diff --git a/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog/rsyslog.conf b/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog/rsyslog.conf
index 3aae03f31..5a85aadb5 100644
--- a/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog/rsyslog.conf
+++ b/meta-facebook/meta-tiogapass/recipes-extended/rsyslog/rsyslog/rsyslog.conf
@@ -25,11 +25,26 @@ template(name="IPMISELTemplate" type="list") {
constant(value="\n")
}
-# If the journal entry has a Redfish MessageId, save as a Redfish event
+# Template for Redfish messages
+# "<timestamp> <MessageId>,<MessageArgs>"
+template(name="RedfishTemplate" type="list") {
+ property(name="timereported" dateFormat="rfc3339")
+ constant(value=" ")
+ property(name="$!REDFISH_MESSAGE_ID")
+ constant(value=",")
+ property(name="$!REDFISH_MESSAGE_ARGS")
+ constant(value="\n")
+}
+
+# If the journal entry has a IPMI SEL MESSAGE_ID, save as IPMI SEL
if ($!IPMISEL_MESSAGE_ID != "") then {
action(type="omfile" file="/var/log/ipmi_sel" template="IPMISELTemplate")
}
+# If the journal entry has a Redfish MessageId, save as a Redfish event
+if ($!REDFISH_MESSAGE_ID != "") then {
+ action(type="omfile" file="/var/log/redfish" template="RedfishTemplate")
+}
#
# Include all config files in /etc/rsyslog.d/
#
diff --git a/meta-facebook/meta-yosemitev2/conf/local.conf.sample b/meta-facebook/meta-yosemitev2/conf/local.conf.sample
index cbbcb84ef..297d077cc 100644
--- a/meta-facebook/meta-yosemitev2/conf/local.conf.sample
+++ b/meta-facebook/meta-yosemitev2/conf/local.conf.sample
@@ -126,12 +126,11 @@ EXTRA_IMAGE_FEATURES = "debug-tweaks"
# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-mklibs' to reduce shared library files size for an image
# - 'image-prelink' in order to prelink the filesystem image
# - 'image-swab' to perform host system intrusion detection
# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+USER_CLASSES ?= "buildstats image-prelink"
#
# Runtime testing of images
diff --git a/meta-facebook/recipes-fb/packagegroups/packagegroup-fb-apps.bb b/meta-facebook/recipes-fb/packagegroups/packagegroup-fb-apps.bb
index b2ec84b65..6b61bba5a 100644
--- a/meta-facebook/recipes-fb/packagegroups/packagegroup-fb-apps.bb
+++ b/meta-facebook/recipes-fb/packagegroups/packagegroup-fb-apps.bb
@@ -5,12 +5,15 @@ inherit packagegroup
PROVIDES = "${PACKAGES}"
PACKAGES = " \
- ${PN}-chassis \
${PN}-extras \
${PN}-fans \
${PN}-flash \
${PN}-system \
"
+PACKAGES_append_fb-withhost = " \
+ ${PN}-chassis \
+ ${PN}-hostmgmt \
+ "
PROVIDES += "virtual/obmc-chassis-mgmt"
PROVIDES += "virtual/obmc-fan-mgmt"
@@ -40,10 +43,8 @@ RDEPENDS_${PN}-flash = " \
phosphor-software-manager \
"
-SUMMARY_${PN}-system = "Facebook System"
-RDEPENDS_${PN}-system = " \
- entity-manager \
- dbus-sensors \
+RDEPENDS_PN_SYSTEM_EXTRAS = ""
+RDEPENDS_PN_SYSTEM_EXTRAS_fb-withhost = " \
fb-powerctrl \
phosphor-ipmi-ipmb \
fb-ipmi-oem \
@@ -52,5 +53,12 @@ RDEPENDS_${PN}-system = " \
ipmitool \
phosphor-post-code-manager \
phosphor-host-postd \
+ "
+
+SUMMARY_${PN}-system = "Facebook System"
+RDEPENDS_${PN}-system = " \
+ entity-manager \
+ dbus-sensors \
phosphor-virtual-sensor \
+ ${RDEPENDS_PN_SYSTEM_EXTRAS} \
"
diff --git a/meta-facebook/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-facebook/recipes-phosphor/images/obmc-phosphor-image.bbappend
new file mode 100644
index 000000000..ad9c87ae4
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+IMAGE_FEATURES_remove_fb-nohost = "obmc-console"
diff --git a/meta-facebook/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-facebook/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
new file mode 100644
index 000000000..dbcc895d4
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PACKAGES_remove_fb-nohost = "\
+ ${PN}-console \
+ "
diff --git a/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor/bletchley/bletchley_sensor_config.json b/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor/bletchley/bletchley_sensor_config.json
new file mode 100644
index 000000000..fe51488c7
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor/bletchley/bletchley_sensor_config.json
@@ -0,0 +1 @@
+[]