summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-core')
-rw-r--r--meta-google/recipes-core/dropbear/dropbear/dropbear.default1
-rw-r--r--meta-google/recipes-core/dropbear/dropbear_%.bbappend7
-rw-r--r--meta-google/recipes-core/systemd/systemd_%.bbappend3
3 files changed, 11 insertions, 0 deletions
diff --git a/meta-google/recipes-core/dropbear/dropbear/dropbear.default b/meta-google/recipes-core/dropbear/dropbear/dropbear.default
new file mode 100644
index 000000000..e5f778145
--- /dev/null
+++ b/meta-google/recipes-core/dropbear/dropbear/dropbear.default
@@ -0,0 +1 @@
+DROPBEAR_EXTRA_ARGS=""
diff --git a/meta-google/recipes-core/dropbear/dropbear_%.bbappend b/meta-google/recipes-core/dropbear/dropbear_%.bbappend
index 20c53fecb..e93eba8b6 100644
--- a/meta-google/recipes-core/dropbear/dropbear_%.bbappend
+++ b/meta-google/recipes-core/dropbear/dropbear_%.bbappend
@@ -1,3 +1,10 @@
+FILESEXTRAPATHS_prepend_gbmc := "${THISDIR}/${PN}:"
+SRC_URI_append_gbmc = " file://dropbear.default"
+SYSTEMD_AUTO_ENABLE_${PN}_prod = "disable"
+
+FILESEXTRAPATHS_remove_gbmc_bandaid := "${THISDIR}/${PN}:"
+SYSTEMD_AUTO_ENABLE_${PN}_bandaid_prod = "enable"
+
# Allow SSH to the mgmt node on DEV builds
do_install_append_gbmc_dev() {
nftables_dir=${D}${sysconfdir}/nftables
diff --git a/meta-google/recipes-core/systemd/systemd_%.bbappend b/meta-google/recipes-core/systemd/systemd_%.bbappend
index 88065e2e0..d40168e45 100644
--- a/meta-google/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-google/recipes-core/systemd/systemd_%.bbappend
@@ -3,3 +3,6 @@ PACKAGECONFIG_append_gbmc = " coredump"
# Disable timesync as we don't use it and it makes rebooting much slower
PACKAGECONFIG_remove_gbmc = "timesyncd"
+
+# We don't need any legacy sysv rc compatability
+PACKAGECONFIG_remove_gbmc = "sysvinit"