summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended/networking/sslh_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-extended/networking/sslh_git.bb')
-rw-r--r--meta-google/recipes-extended/networking/sslh_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-google/recipes-extended/networking/sslh_git.bb b/meta-google/recipes-extended/networking/sslh_git.bb
index 16c8f3279..ba26e2999 100644
--- a/meta-google/recipes-extended/networking/sslh_git.bb
+++ b/meta-google/recipes-extended/networking/sslh_git.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
PV = "0.1+git${SRCPV}"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
@@ -7,6 +7,9 @@ SRC_URI = "git://github.com/yrutschle/sslh"
SRCREV = "63f9c4a582f79f4d0e484efe0ccaeed77a79f7df"
S = "${WORKDIR}/git"
+inherit perlnative
+
+DEPENDS += "conf2struct-native"
DEPENDS += "libbsd"
DEPENDS += "libcap"
DEPENDS += "libconfig"
@@ -19,13 +22,13 @@ EXTRA_OEMAKE += "USELIBCAP=1"
EXTRA_OEMAKE += "USELIBBSD=1"
EXTRA_OEMAKE += "USESYSTEMD=1"
-do_patch() {
- # Workaround timestamps of the source being later than the generated,
- # vendored output files. This non-determinism sometimes causes failures.
- sed -i '/conf2struct/d' ${S}/Makefile
+do_configure() {
+ oe_runmake distclean
}
do_compile() {
+ # Workaround for the broken dependencies in the Makefile
+ oe_runmake sslh-conf.h
oe_runmake
}