summaryrefslogtreecommitdiff
path: root/meta-google/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-extended')
-rw-r--r--meta-google/recipes-extended/networking/sslh_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta-google/recipes-extended/networking/sslh_git.bb b/meta-google/recipes-extended/networking/sslh_git.bb
index b683571c1..5a7a9b14e 100644
--- a/meta-google/recipes-extended/networking/sslh_git.bb
+++ b/meta-google/recipes-extended/networking/sslh_git.bb
@@ -7,9 +7,6 @@ SRC_URI = "git://github.com/yrutschle/sslh"
SRCREV = "517e4ad5b4d57dae396790882bd4629947be1632"
S = "${WORKDIR}/git"
-inherit perlnative
-
-DEPENDS += "conf2struct-native"
DEPENDS += "libbsd"
DEPENDS += "libcap"
DEPENDS += "libconfig"
@@ -22,10 +19,16 @@ EXTRA_OEMAKE += "USELIBCAP=1"
EXTRA_OEMAKE += "USELIBBSD=1"
EXTRA_OEMAKE += "USESYSTEMD=1"
+do_patch() {
+ # Workaround timestamps of the source being later than the generated,
+ # vendored output files. This non-determinism sometimes causes failures.
+ sed -i '/conf2struct/d' ${S}/Makefile
+}
+
do_compile() {
- oe_runmake
+ oe_runmake
}
do_install() {
- oe_runmake install
+ oe_runmake install
}