summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/networking')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb10
-rw-r--r--meta-google/recipes-google/networking/gbmc-ip-monitor.bb6
-rw-r--r--meta-google/recipes-google/networking/gbmc-iperf3.bb6
-rw-r--r--meta-google/recipes-google/networking/gbmc-mac-config.bb8
-rw-r--r--meta-google/recipes-google/networking/google-usb-network_git.bb10
-rw-r--r--meta-google/recipes-google/networking/network-sh.bb6
6 files changed, 23 insertions, 23 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 37af84baf..dea14f00b 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += " \
file://-bmc-gbmcbr.netdev \
file://-bmc-gbmcbr.network.in \
@@ -22,14 +22,14 @@ SRC_URI += " \
file://gbmc-br-nft.sh \
"
-FILES_${PN}_append = " \
+FILES:${PN}:append = " \
${datadir}/gbmc-ip-monitor \
${systemd_unitdir}/network \
${sysconfdir}/nftables \
${sysconfdir}/avahi/services \
"
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
bash \
gbmc-ip-monitor \
mstpd-mstpd \
@@ -37,7 +37,7 @@ RDEPENDS_${PN}_append = " \
ndisc6-rdisc6 \
"
-SYSTEMD_SERVICE_${PN} += "gbmc-br-ensure-ra.service"
+SYSTEMD_SERVICE:${PN} += "gbmc-br-ensure-ra.service"
GBMC_BR_MAC_ADDR ?= ""
@@ -98,7 +98,7 @@ do_install() {
install -m0755 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
}
-do_rm_work_prepend() {
+do_rm_work:prepend() {
# HACK: Work around broken do_rm_work not properly calling rm with `--`
# It doesn't like filenames that start with `-`
rm -rf -- ${WORKDIR}/-*
diff --git a/meta-google/recipes-google/networking/gbmc-ip-monitor.bb b/meta-google/recipes-google/networking/gbmc-ip-monitor.bb
index 32804302b..1bf35bc9c 100644
--- a/meta-google/recipes-google/networking/gbmc-ip-monitor.bb
+++ b/meta-google/recipes-google/networking/gbmc-ip-monitor.bb
@@ -15,18 +15,18 @@ S = "${WORKDIR}"
DEPENDS += "test-sh"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
bash \
iproute2 \
"
-SYSTEMD_SERVICE_${PN} += "gbmc-ip-monitor.service"
+SYSTEMD_SERVICE:${PN} += "gbmc-ip-monitor.service"
do_compile() {
SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash gbmc-ip-monitor-test.sh || exit
}
-do_install_append() {
+do_install:append() {
install -d -m0755 ${D}${libexecdir}
install -m0755 gbmc-ip-monitor.sh ${D}${libexecdir}/
diff --git a/meta-google/recipes-google/networking/gbmc-iperf3.bb b/meta-google/recipes-google/networking/gbmc-iperf3.bb
index 27ebdb7e0..3b78a405f 100644
--- a/meta-google/recipes-google/networking/gbmc-iperf3.bb
+++ b/meta-google/recipes-google/networking/gbmc-iperf3.bb
@@ -5,11 +5,11 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
-RDEPENDS_${PN} += "iperf3"
+RDEPENDS:${PN} += "iperf3"
SRC_URI += "file://iperf3.service"
-SYSTEMD_SERVICE_${PN} += "iperf3.service"
+SYSTEMD_SERVICE:${PN} += "iperf3.service"
do_install() {
# Install service definitions
@@ -18,7 +18,7 @@ do_install() {
}
# Allow IPERF3 to run on the gbmcbr node on DEV builds
-do_install_append_dev() {
+do_install:append:dev() {
nftables_dir=${D}${sysconfdir}/nftables
rules=$nftables_dir/50-gbmc-iperf3-dev.rules
install -d -m0755 $nftables_dir
diff --git a/meta-google/recipes-google/networking/gbmc-mac-config.bb b/meta-google/recipes-google/networking/gbmc-mac-config.bb
index 6ca4c798b..7a3781d1f 100644
--- a/meta-google/recipes-google/networking/gbmc-mac-config.bb
+++ b/meta-google/recipes-google/networking/gbmc-mac-config.bb
@@ -12,14 +12,14 @@ SRC_URI += " \
S = "${WORKDIR}"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
bash \
ipmi-fru-sh \
"
-FILES_${PN} += "${systemd_unitdir}"
+FILES:${PN} += "${systemd_unitdir}"
-SYSTEMD_SERVICE_${PN} += "gbmc-mac-config.service"
+SYSTEMD_SERVICE:${PN} += "gbmc-mac-config.service"
GBMC_MAC_EEPROM_OF_NAME ?= ""
@@ -28,7 +28,7 @@ GBMC_MAC_EEPROM_OF_NAME ?= ""
# Ex. "[0]=eth0 [2]=eth2"
GBMC_MAC_IF_MAP ?= ""
-do_install_append() {
+do_install:append() {
if [ -z '${GBMC_MAC_EEPROM_OF_NAME}' ]; then
echo 'Missing GBMC_MAC_EEPROM_OF_NAME' >&2
exit 1
diff --git a/meta-google/recipes-google/networking/google-usb-network_git.bb b/meta-google/recipes-google/networking/google-usb-network_git.bb
index ec51eaa5b..f0d15b94e 100644
--- a/meta-google/recipes-google/networking/google-usb-network_git.bb
+++ b/meta-google/recipes-google/networking/google-usb-network_git.bb
@@ -6,16 +6,16 @@ PV = "0.2"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-FILESEXTRAPATHS_prepend = "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend = "${THISDIR}/${PN}:"
inherit systemd
DEPENDS += "m4-native"
DEPENDS += "systemd"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "bash"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "usb_network.service"
+SYSTEMD_SERVICE:${PN} = "usb_network.service"
BMC_IP_ADDR ??= "169.254.95.118/16"
BMC_USB_ECM_PRODUCT_ID ??= ""
@@ -30,8 +30,8 @@ SRC_URI += "file://00-bmc-usb0.network.m4"
SRC_URI += "file://usb_network.service.m4"
SRC_URI += "file://usb_network.sh"
-FILES_${PN} = "${bindir}/usb_network.sh"
-FILES_${PN}_append = " ${systemd_unitdir}/network/${BMC_USB_CONFIG_FILENAME}"
+FILES:${PN} = "${bindir}/usb_network.sh"
+FILES:${PN}:append = " ${systemd_unitdir}/network/${BMC_USB_CONFIG_FILENAME}"
do_compile() {
test "X${BMC_IP_ADDR}" != "X" || bberror "Please define BMC_IP_ADDR"
diff --git a/meta-google/recipes-google/networking/network-sh.bb b/meta-google/recipes-google/networking/network-sh.bb
index a377b9e2a..921795b00 100644
--- a/meta-google/recipes-google/networking/network-sh.bb
+++ b/meta-google/recipes-google/networking/network-sh.bb
@@ -3,13 +3,13 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://lib.sh"
SRC_URI += "file://test.sh"
S = "${WORKDIR}"
DATA = "${datadir}/network"
-FILES_${PN} += "${DATA}"
+FILES:${PN} += "${DATA}"
DEPENDS += "test-sh"
@@ -17,7 +17,7 @@ do_compile() {
SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash test.sh || exit
}
-do_install_append() {
+do_install:append() {
install -d -m0755 ${D}${DATA}
install -m0644 lib.sh ${D}${DATA}/
}