summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/nftables/nftables-systemd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/nftables/nftables-systemd.bb')
-rw-r--r--meta-google/recipes-google/nftables/nftables-systemd.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-google/recipes-google/nftables/nftables-systemd.bb b/meta-google/recipes-google/nftables/nftables-systemd.bb
index 03694c8c5..f4109ddc7 100644
--- a/meta-google/recipes-google/nftables/nftables-systemd.bb
+++ b/meta-google/recipes-google/nftables/nftables-systemd.bb
@@ -8,7 +8,11 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit systemd
-SRC_URI += "file://nftables.service"
+SRC_URI += " \
+ file://nft-configure.sh \
+ file://nftables.service \
+ "
+
SYSTEMD_SERVICE_${PN} += "nftables.service"
RDEPENDS_${PN} += " \
@@ -17,6 +21,9 @@ RDEPENDS_${PN} += " \
"
do_install() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}
+ install -d ${D}${libexecdir}
+ install -m0755 ${WORKDIR}/nft-configure.sh ${D}${libexecdir}/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}/
}