summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/google-key.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-phosphor/flash/google-key.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/google-key.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/flash/google-key.bb b/meta-google/recipes-phosphor/flash/google-key.bb
new file mode 100644
index 000000000..220211526
--- /dev/null
+++ b/meta-google/recipes-phosphor/flash/google-key.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Google Key installation Script"
+DESCRIPTION = "Google Key installation Script"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+RDEPENDS_${PN} += "bash"
+RDEPENDS_${PN} += "gnupg"
+
+SRC_URI += " \
+ file://platforms_gbmc_bringup.gpg \
+ file://platforms_gbmc_secure.gpg \
+ file://verify-bmc-image.sh \
+"
+
+do_install() {
+ # Install keys into image.
+ install -d -m 0755 ${D}${datadir}/google-key
+ install -m 0644 ${WORKDIR}/platforms_gbmc_secure.gpg ${D}${datadir}/google-key/prod.key
+ install -m 0644 ${WORKDIR}/platforms_gbmc_bringup.gpg ${D}${datadir}/google-key/dev.key
+
+ # Install the verification helper
+ install -d -m 0755 ${D}${bindir}
+ install -m 0755 ${WORKDIR}/verify-bmc-image.sh ${D}${bindir}
+}