summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
index c71a579e1..9e55afce5 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
@@ -8,10 +8,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
PROVIDES += "virtual/bmc-update"
-RPROVIDES_${PN} += "virtual/bmc-update"
+RPROVIDES:${PN} += "virtual/bmc-update"
-RDEPENDS_${PN} += "google-key"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "google-key"
+RDEPENDS:${PN} += "bash"
SRC_URI += " \
file://config-bmc.json \
@@ -21,10 +21,10 @@ SRC_URI += " \
file://inplace-gbmc-version.sh \
"
-SYSTEMD_SERVICE_${PN} += "inplace-gbmc-verify.service"
-SYSTEMD_SERVICE_${PN} += "inplace-gbmc-version.service"
+SYSTEMD_SERVICE:${PN} += "inplace-gbmc-verify.service"
+SYSTEMD_SERVICE:${PN} += "inplace-gbmc-version.service"
-FILES_${PN} += "${datadir}/phosphor-ipmi-flash"
+FILES:${PN} += "${datadir}/phosphor-ipmi-flash"
do_install() {
sed -i 's,@ALLOW_DEV@,,' ${WORKDIR}/inplace-gbmc-verify.sh
@@ -39,6 +39,6 @@ do_install() {
install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
}
-do_install_prepend_dev() {
+do_install:prepend:dev() {
sed -i 's,@ALLOW_DEV@,--allow-dev,' ${WORKDIR}/inplace-gbmc-verify.sh
}