summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-phosphor/flash')
-rw-r--r--meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb4
-rw-r--r--meta-google/recipes-phosphor/flash/google-key.bb4
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb14
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-verify.sh2
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-version.sh2
5 files changed, 13 insertions, 13 deletions
diff --git a/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb b/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
index 7eba3b0fc..4bff6e331 100644
--- a/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
@@ -10,9 +10,9 @@ inherit systemd
SRC_URI += "file://config-dummy.json"
SRC_URI += "file://dummy-verify.service"
-FILES_${PN} += "${datadir}/phosphor-ipmi-flash"
+FILES:${PN} += "${datadir}/phosphor-ipmi-flash"
-SYSTEMD_SERVICE_${PN} += "dummy-verify.service"
+SYSTEMD_SERVICE:${PN} += "dummy-verify.service"
do_install() {
install -d ${D}${datadir}/phosphor-ipmi-flash
diff --git a/meta-google/recipes-phosphor/flash/google-key.bb b/meta-google/recipes-phosphor/flash/google-key.bb
index 220211526..f05f08245 100644
--- a/meta-google/recipes-phosphor/flash/google-key.bb
+++ b/meta-google/recipes-phosphor/flash/google-key.bb
@@ -5,8 +5,8 @@ PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS_${PN} += "bash"
-RDEPENDS_${PN} += "gnupg"
+RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += "gnupg-gpg"
SRC_URI += " \
file://platforms_gbmc_bringup.gpg \
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
index c71a579e1..9e55afce5 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
@@ -8,10 +8,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
PROVIDES += "virtual/bmc-update"
-RPROVIDES_${PN} += "virtual/bmc-update"
+RPROVIDES:${PN} += "virtual/bmc-update"
-RDEPENDS_${PN} += "google-key"
-RDEPENDS_${PN} += "bash"
+RDEPENDS:${PN} += "google-key"
+RDEPENDS:${PN} += "bash"
SRC_URI += " \
file://config-bmc.json \
@@ -21,10 +21,10 @@ SRC_URI += " \
file://inplace-gbmc-version.sh \
"
-SYSTEMD_SERVICE_${PN} += "inplace-gbmc-verify.service"
-SYSTEMD_SERVICE_${PN} += "inplace-gbmc-version.service"
+SYSTEMD_SERVICE:${PN} += "inplace-gbmc-verify.service"
+SYSTEMD_SERVICE:${PN} += "inplace-gbmc-version.service"
-FILES_${PN} += "${datadir}/phosphor-ipmi-flash"
+FILES:${PN} += "${datadir}/phosphor-ipmi-flash"
do_install() {
sed -i 's,@ALLOW_DEV@,,' ${WORKDIR}/inplace-gbmc-verify.sh
@@ -39,6 +39,6 @@ do_install() {
install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
}
-do_install_prepend_dev() {
+do_install:prepend:dev() {
sed -i 's,@ALLOW_DEV@,--allow-dev,' ${WORKDIR}/inplace-gbmc-verify.sh
}
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-verify.sh b/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-verify.sh
index d5307d3d1..e7727cd72 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-verify.sh
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-verify.sh
@@ -54,4 +54,4 @@ echo "running" > ${STATUS_FILE}
verify-bmc-image.sh @ALLOW_DEV@ "$IMAGE_FILE" "$SIGNATURE_FILE" || exit
# Rename the staged file for initramfs updates.
-mv ${IMAGE_FILE} ${VERIFIED_FILE}#!/bin/bash
+mv ${IMAGE_FILE} ${VERIFIED_FILE}
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-version.sh b/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-version.sh
index 0c5c4e787..039101876 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-version.sh
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update/inplace-gbmc-version.sh
@@ -13,4 +13,4 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-grep '^VERSION_ID=' /etc/os-release | sed 's,.*-\([^-]*\),\1,g' | tr -d '\n'#!/bin/bash
+grep '^VERSION_ID=' /etc/os-release | sed 's,.*-\([^-]*\),\1,g' | tr -d '\n'