summaryrefslogtreecommitdiff
path: root/meta-hpe/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hpe/conf')
-rw-r--r--meta-hpe/conf/layer.conf13
-rw-r--r--meta-hpe/conf/machine/include/hpe.inc19
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-hpe/conf/layer.conf b/meta-hpe/conf/layer.conf
new file mode 100644
index 000000000..3d2fce1f3
--- /dev/null
+++ b/meta-hpe/conf/layer.conf
@@ -0,0 +1,13 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "hpe-layer"
+BBFILE_PATTERN_hpe-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_hpe-layer = "zeus warrior dunfell"
+
+# Provide a variable that points the base of the hpe layer.
+HPEBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-hpe/conf/machine/include/hpe.inc b/meta-hpe/conf/machine/include/hpe.inc
new file mode 100644
index 000000000..1e928beeb
--- /dev/null
+++ b/meta-hpe/conf/machine/include/hpe.inc
@@ -0,0 +1,19 @@
+OBMC_MACHINE_FEATURES += "\
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-flash-mgmt \
+ obmc-host-ipmi \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-bmc-state-mgmt \
+ "
+
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-hpe-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
+#PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-hostfw-config ?= "hostboot-inventory-config-native"
+
+IMAGE_FEATURES_remove = "obmc-fan-control"