summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend')
-rw-r--r--meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
new file mode 100644
index 000000000..ad672452a
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
@@ -0,0 +1,23 @@
+
+
+do_generate_hpe_image() {
+ # Add gxp-bootblock to hpe-section
+ dd bs=1k conv=notrunc seek=64 \
+ if=${DEPLOY_DIR_IMAGE}/${HPE_GXP_BOOTBLOCK_IMAGE} \
+ of=${DEPLOY_DIR_IMAGE}/hpe-section
+}
+
+do_generate_static_tar() {
+
+ ln -sf ${S}/MANIFEST MANIFEST
+ ln -sf ${S}/publickey publickey
+ make_image_links ${OVERLAY_BASETYPE} ${IMAGE_BASETYPE}
+
+ make_signatures image-u-boot image-kernel image-rofs image-rwfs image-section MANIFEST publickey
+ make_tar_of_images static MANIFEST publickey ${signature_files}
+
+ # Maintain non-standard legacy link.
+ cd ${IMGDEPLOYDIR}
+ ln -sf ${IMAGE_NAME}.static.mtd.tar ${IMGDEPLOYDIR}/${MACHINE}-${DATETIME}.tar
+}
+