summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-dl360poc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hpe/meta-dl360poc')
-rw-r--r--meta-hpe/meta-dl360poc/conf/layer.conf2
-rw-r--r--meta-hpe/meta-dl360poc/conf/local.conf.sample141
-rw-r--r--meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb1
-rw-r--r--meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend1
-rw-r--r--meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh40
-rw-r--r--meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts256
-rw-r--r--meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc_%.bbappend4
-rw-r--r--meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend2
8 files changed, 247 insertions, 200 deletions
diff --git a/meta-hpe/meta-dl360poc/conf/layer.conf b/meta-hpe/meta-dl360poc/conf/layer.conf
index 5f85f7c1c..999ad04fc 100644
--- a/meta-hpe/meta-dl360poc/conf/layer.conf
+++ b/meta-hpe/meta-dl360poc/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "dl360poc-layer"
BBFILE_PATTERN_dl360poc-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_dl360poc-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_dl360poc-layer = "hardknott honister"
diff --git a/meta-hpe/meta-dl360poc/conf/local.conf.sample b/meta-hpe/meta-dl360poc/conf/local.conf.sample
index a111ba715..41698669b 100644
--- a/meta-hpe/meta-dl360poc/conf/local.conf.sample
+++ b/meta-hpe/meta-dl360poc/conf/local.conf.sample
@@ -2,11 +2,11 @@
# This file is your local configuration file and is where all local user settings
# are placed. The comments in this file give some guide to the options a new user
# to the system might want to change but pretty much any configuration option can
-# be set in this file. More adventurous users can look at local.conf.extended
+# be set in this file. More adventurous users can look at local.conf.extended
# which contains other examples of configuration which can be placed in this file
# but new users likely won't need any of them initially.
#
-# Lines starting with the '#' character are commented out and in some cases the
+# Lines starting with the '#' character are commented out and in some cases the
# default values are provided as comments to show people example syntax. Enabling
# the option is a question of removing the # character and making any change to the
# variable as required.
@@ -14,26 +14,6 @@
#
# Machine Selection
#
-# You need to select a specific machine to target the build with. There are a selection
-# of emulated machines available which can boot and run in the QEMU emulator:
-#
-#MACHINE ?= "qemuarm"
-#MACHINE ?= "qemuarm64"
-#MACHINE ?= "qemumips"
-#MACHINE ?= "qemuppc"
-#MACHINE ?= "qemux86"
-#MACHINE ?= "qemux86-64"
-#
-# There are also the following hardware board target machines included for
-# demonstration purposes:
-#
-#MACHINE ?= "beaglebone"
-#MACHINE ?= "genericx86"
-#MACHINE ?= "genericx86-64"
-#MACHINE ?= "mpc8315e-rdb"
-#MACHINE ?= "edgerouter"
-#
-# This sets the default machine to be qemux86 if no other machine is selected:
MACHINE ??= "dl360poc"
#
@@ -82,12 +62,12 @@ MACHINE ??= "dl360poc"
#
# The distribution setting controls which policy settings are used as defaults.
# The default value is fine for general Yocto project use, at least initially.
-# Ultimately when creating custom policy, people will likely end up subclassing
+# Ultimately when creating custom policy, people will likely end up subclassing
# these defaults.
#
DISTRO ?= "openbmc-phosphor"
# As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream
+# where many versions are set to the absolute latest code from the upstream
# source control systems. This is just mentioned here as an example, its not
# useful to most new users.
# DISTRO ?= "poky-bleeding"
@@ -95,8 +75,8 @@ DISTRO ?= "openbmc-phosphor"
#
# Package Management configuration
#
-# This variable lists which packaging formats to enable. Multiple package backends
-# can be enabled at once and the first item listed in the variable will be used
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
# to generate the root filesystems.
# Options are:
# - 'package_deb' for debian style deb files
@@ -107,24 +87,26 @@ DISTRO ?= "openbmc-phosphor"
PACKAGE_CLASSES ?= "package_rpm"
#
-# SDK/ADT target architecture
+# SDK target architecture
#
-# This variable specifies the architecture to build SDK/ADT items for and means
-# you can build the SDK packages for architectures other than the machine you are
+# This variable specifies the architecture to build SDK items for and means
+# you can build the SDK packages for architectures other than the machine you are
# running the build on (i.e. building i686 packages on an x86_64 host).
-# Supported values are i686 and x86_64
+# Supported values are i686, x86_64, aarch64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
+SANITY_TESTED_DISTROS:append ?= " *"
#
# Extra image configuration defaults
#
-# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
# images. Some of these options are added to certain image types automatically. The
# variable can contain the following options:
# "dbg-pkgs" - add -dbg packages for all installed packages
# (adds symbol information for debugging/profiling)
+# "src-pkgs" - add -src packages for all installed packages
+# (adds source code for debugging)
# "dev-pkgs" - add -dev packages for all installed packages
# (useful if you want to develop against libs in the image)
# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
@@ -132,41 +114,39 @@ SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
# "tools-debug" - add debugging tools (gdb, strace)
# "eclipse-debug" - add Eclipse remote debugging support
-# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
# "debug-tweaks" - make an image suitable for development
# e.g. ssh root access has a blank password
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
#
# Additional image features
#
# The following is a list of additional classes to use when building images which
-# enable extra features. Some available options which can be included in this variable
+# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-prelink' in order to prelink the filesystem image
-# - 'image-swab' to perform host system intrusion detection
-# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
-# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-prelink"
+USER_CLASSES ?= "buildstats"
#
# Runtime testing of images
#
# The build system can test booting virtual machine images under qemu (an emulator)
-# after any root filesystems are created and run tests against those images. To
-# enable this uncomment this line. See classes/testimage(-auto).bbclass for
-# further details.
-#TEST_IMAGE = "1"
+# after any root filesystems are created and run tests against those images. It can also
+# run tests against any SDK that are built. To enable this uncomment these lines.
+# See classes/test{image,sdk}.bbclass for further details.
+#IMAGE_CLASSES += "testimage testsdk"
+#TESTIMAGE_AUTO:qemuall = "1"
+
#
# Interactive shell configuration
#
-# Under certain circumstances the system may need input from you and to do this it
-# can launch an interactive shell. It needs to do this since the build is
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
# multithreaded and needs to be able to handle the case where more than one parallel
# process may require the user's attention. The default is iterate over the available
# terminal types to find one that works.
@@ -186,12 +166,12 @@ PATCHRESOLVE = "noop"
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less than 100MB or 1K inodes, perform a hard abort
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necessary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
@@ -204,13 +184,13 @@ BB_DISKMON_DIRS = "\
#
# Shared-state files from other locations
#
-# As mentioned above, shared state files are prebuilt cache data objects which can
+# As mentioned above, shared state files are prebuilt cache data objects which can be
# used to accelerate build time. This variable can be used to configure the system
# to search other mirror locations for these objects before it builds the data itself.
#
# This can be a filesystem directory, or a remote url such as http or ftp. These
-# would contain the sstate-cache results from previous builds (possibly from other
-# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
# cache locations to check for the shared objects.
# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
# at the end as shown in the examples below. This will be substituted with the
@@ -219,26 +199,57 @@ BB_DISKMON_DIRS = "\
#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
#file://.* file:///some/local/dir/sstate/PATH"
+#
+# Yocto Project SState Mirror
+#
+# The Yocto Project has prebuilt artefacts available for its releases, you can enable
+# use of these by uncommenting the following line. This will mean the build uses
+# the network to check for artefacts at the start of builds, which does slow it down
+# equally, it will also speed up the builds by not having to build things if they are
+# present in the cache. It assumes you can download something faster than you can build it
+# which will depend on your network.
+#
+#SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/2.5/PATH;downloadfilename=PATH"
#
# Qemu configuration
#
-# By default qemu will build with a builtin VNC server where graphical output can be
-# seen. The two lines below enable the SDL backend too. This assumes there is a
-# libsdl library available on your build system.
-PACKAGECONFIG_append_pn-qemu-native = " sdl"
-PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
-#ASSUME_PROVIDED += "libsdl-native"
+# By default native qemu will build with a builtin VNC server where graphical output can be
+# seen. The line below enables the SDL UI frontend too.
+#PACKAGECONFIG:append:pn-qemu-system-native = " sdl"
+# By default libsdl2-native will be built, if you want to use your host's libSDL instead of
+# the minimal libsdl built by libsdl2-native then uncomment the ASSUME_PROVIDED line below.
+#ASSUME_PROVIDED += "libsdl2-native"
+# You can also enable the Gtk UI frontend, which takes somewhat longer to build, but adds
+# a handy set of menus for controlling the emulator.
+#PACKAGECONFIG:append:pn-qemu-system-native = " gtk+"
+
+#
+# Hash Equivalence
+#
+# Enable support for automatically running a local hash equivalence server and
+# instruct bitbake to use a hash equivalence aware signature generator. Hash
+# equivalence improves reuse of sstate by detecting when a given sstate
+# artifact can be reused as equivalent, even if the current task hash doesn't
+# match the one that generated the artifact.
+#
+# A shared hash equivalent server can be set with "<HOSTNAME>:<PORT>" format
+#
+#BB_HASHSERVE = "auto"
+#BB_SIGNATURE_HANDLER = "OEEquivHash"
+
+#
+# Memory Resident Bitbake
+#
+# Bitbake's server component can stay in memory after the UI for the current command
+# has completed. This means subsequent commands can run faster since there is no need
+# for bitbake to reload cache files and so on. Number is in seconds, after which the
+# server will shut down.
+#
+#BB_SERVER_TIMEOUT = "60"
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
-
-# Set the root password to '0penBmc'
-INHERIT += "extrausers"
-
-EXTRA_USERS_PARAMS = " \
- usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root; \
- "
+CONF_VERSION = "2"
diff --git a/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb b/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb
new file mode 100644
index 000000000..969937551
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-bsp/image/gxp-bootblock.bb
@@ -0,0 +1 @@
+inherit gxp-bootblock-n-poc
diff --git a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend
new file mode 100644
index 000000000..4fc41d058
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh
new file mode 100644
index 000000000..08b882d6d
--- /dev/null
+++ b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh
@@ -0,0 +1,40 @@
+#!/bin/sh
+
+findmtd() {
+ m=$(grep -xl "$1" /sys/class/mtd/*/name)
+ m=${m%/name}
+ m=${m##*/}
+ echo $m
+}
+
+rom_lists=(host-prime host-second vrom-prime vrom-second)
+rom_mtd_list=()
+
+for f in "${rom_lists[@]}"
+do
+ image=$(findmtd ${f})
+ if test -z "$image"
+ then
+ echo "Unable to find mtd partition for ${f}"
+ exit 1
+ fi
+ rom_mtd_list+=($image)
+done
+
+#enable vrom
+# host-prime to vrom-prime
+dd if=/dev/${rom_mtd_list[0]} of=/dev/${rom_mtd_list[2]}
+# host-second to vrom-second
+dd if=/dev/${rom_mtd_list[1]} of=/dev/${rom_mtd_list[3]}
+
+echo 0x1800008a > /sys/class/soc/srom/vromoff
+
+while [ true ]
+do
+ devmem 0x8000005C 8 0
+ devmem 0xd1000306 8 5
+ devmem 0xd1000318 8 0x03
+ devmem 0xd100030f 8 0x04
+ sleep 1
+done
+
diff --git a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
index c11ccb023..92f933b50 100644
--- a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
+++ b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc/gxp.dts
@@ -44,7 +44,7 @@
interrupt-parent = <&vic0>;
clock-frequency = <400000000>;
};
-
+
watchdog: watchdog@c0000090 {
compatible = "hpe,gxp-wdt";
reg = <0xc0000090 0x02>, <0xc0000096 0x01>;
@@ -82,7 +82,7 @@
reg = <0x80fc0230 0x100>;
reg-io-width = <1>;
};
-
+
vuart_a: vuart_a@80fd0200 {
compatible = "hpe,gxp-vuart";
reg = <0x80fd0200 0x100>;
@@ -94,7 +94,21 @@
serial-line = <3>;
vuart_cfg = <&vuart_a_cfg>;
};
-
+
+ usb0: ehci@cefe0000 {
+ compatible = "generic-ehci";
+ reg = <0xcefe0000 0x100>;
+ interrupts = <7>;
+ interrupt-parent = <&vic0>;
+ };
+
+ usb1: ohci@cefe0100 {
+ compatible = "generic-ohci";
+ reg = <0xcefe0100 0x110>;
+ interrupts = <6>;
+ interrupt-parent = <&vic0>;
+ };
+
spifi0: spifi@c0000200 {
compatible = "hpe,gxp-spifi";
reg = <0xc0000200 0x80>, <0xc000c000 0x100>, <0xf8000000 0x8000000>;
@@ -110,7 +124,11 @@
compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;
-
+
+ bmc@0 {
+ label = "bmc";
+ reg = <0x0 0x2000000>;
+ };
u-boot@0 {
label = "u-boot";
reg = <0x0 0x60000>;
@@ -132,7 +150,7 @@
reg = <0x1c80000 0x250000>;
};
section@1edf000{
- labele = "section";
+ label = "section";
reg = <0x1ed0000 0x130000>;
};
};
@@ -197,7 +215,7 @@
compatible = "syscon";
reg = <0xc00000f8 0x08>;
};
-
+
i2c0: i2c@c0002000 {
compatible = "hpe,gxp-i2c";
reg = <0xc0002000 0x70>;
@@ -227,8 +245,8 @@
#address-cells = <1>;
#size-cells = <0>;
- at24c02@50 {
- compatible = "at24,24c02";
+ 24c02@50 {
+ compatible = "atmel,24c02";
pagesize = <8>;
reg = <0x50>;
};
@@ -260,18 +278,6 @@
interrupts = <9>;
interrupt-parent = <&vic0>;
i2cg-handle = <&i2cg>;
- #address-cells = <1>;
- #size-cells = <0>;
-
- emc1402@4c {
- compatible = "emc1402";
- reg = <0x4c>;
- };
-
- emc1404@1c {
- compatible = "emc1404";
- reg = <0x1c>;
- };
};
i2c6: i2c@c0002600 {
@@ -441,7 +447,7 @@
compatible = "hpe,gxp-kcs-bmc-cfg", "simple-mfd", "syscon";
reg = <0x80fc0430 0x100>;
};
-
+
kcs_reg: kcs_reg@080fd0400 {
compatible = "hpe,gxp-kcs-bmc";
reg = <0x80fd0400 0x8>;
@@ -460,9 +466,23 @@
height = <600>;
};
- xreg: xreg@d1000000 {
+ xreg: xreg@d1000300 {
compatible = "hpe,gxp-xreg", "simple-mfd", "syscon";
reg = <0xd1000300 0xFF>;
+ interrupts = <26>;
+ interrupt-parent = <&vic0>;
+ #gpio-cells = <2>;
+ gpio-line-names =
+ "", "", "", "", "", "", "POWER", "HEARTBEAT", "FAN1_INST", "FAN2_INST",
+ "FAN3_INST", "FAN4_INST", "FAN5_INST", "FAN6_INST", "FAN7_INST", "FAN8_INST", "FAN9_INST", "FAN10_INST", "FAN11_INST", "FAN12_INST",
+ "FAN13_INST", "FAN14_INST", "FAN15_INST", "FAN16_INST", "FAN1_FAIL", "FAN2_FAIL", "FAN3_FAIL", "FAN4_FAIL", "FAN5_FAIL", "FAN6_FAIL",
+ "FAN7_FAIL", "FAN8_FAIL", "FAN9_FAIL", "FAN10_FAIL", "FAN11_FAIL", "FAN12_FAIL", "FAN13_FAIL", "FAN14_FAIL", "FAN15_FAIL", "FAN16_FAIL",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "IDENTIFY", "HEALTH_RED", "HEALTH_AMBER", "POWER_BUTTON",
+ "", "SIO_POWER_GOOD", "NMI_BUTTON", "RESET_BUTTON", "SIO_S5", "SIO_ONCONTROL", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
};
fanctrl: fanctrl@c1000c00 {
@@ -475,154 +495,107 @@
fn2: fn2@80200000 {
compatible = "hpe,gxp-fn2", "simple-mfd", "syscon";
reg = <0x80200000 0x100000>;
+ xreg_handle = <&xreg>;
interrupts = <0>;
interrupt-parent = <&vic1>;
+ #gpio-cells = <2>;
+ gpio-line-names =
+ "POWER_OUT", "PS_PWROK", "PCIERST", "POST_COMPLETE", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
+ chif {
+ compatible = "hpe,gxp-chif";
+ interrupts = <12>;
+ };
};
csm: csm@80000000 {
compatible = "hpe,gxp-csm", "simple-mfd", "syscon";
- reg = <0x80000000 0x100000>;
+ reg = <0x80000000 0x400>;
};
- gpio: gpio {
+ gpio: gpio@0 {
compatible = "hpe,gxp-gpio";
#gpio-cells = <2>;
csm_handle = <&csm>;
- fn2_handle = <&fn2>;
- xreg_handle = <&xreg>;
vuhc0_handle = <&vuhc0>;
- interrupts = <26>;
- interrupt-parent = <&vic0>;
+ gpio-line-names =
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "RESET_OUT", "NMI_OUT", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "",
+ "", "", "", "", "", "", "", "", "", "";
};
leds: leds {
compatible = "gpio-leds";
power {
- gpios = <&gpio 306 0>;
+ gpios = <&xreg 6 0>;
default-state = "off";
};
heartbeat {
- gpios = <&gpio 307 0>;
+ gpios = <&xreg 7 0>;
default-state = "off";
};
identify {
- gpios = <&gpio 356 0>;
+ gpios = <&xreg 56 0>;
default-state = "off";
};
health_red {
- gpios = <&gpio 357 0>;
+ gpios = <&xreg 57 0>;
default-state = "off";
};
health_amber {
- gpios = <&gpio 358 0>;
+ gpios = <&xreg 58 0>;
default-state = "off";
};
};
- presence: presence {
+ xreg_kyes: xreg_keys {
compatible = "gpio-keys-polled";
poll-interval = <100>;
- autorepeat;
- fan1 {
- label = "fan1 presence";
+ IdButton {
+ label = "ID Button";
linux,code = <200>;
- gpios = <&gpio 308 0>;
- };
-
- fan2 {
- label = "fan2 presence";
- linux,code = <201>;
- gpios = <&gpio 309 0>;
- };
-
- fan3 {
- label = "fan3 presence";
- linux,code = <202>;
- gpios = <&gpio 310 0>;
- };
-
- fan4 {
- label = "fan4 presence";
- linux,code = <203>;
- gpios = <&gpio 311 0>;
- };
-
- fan5 {
- label = "fan5 presence";
- linux,code = <204>;
- gpios = <&gpio 312 0>;
- };
-
- fan6 {
- label = "fan6 presence";
- linux,code = <205>;
- gpios = <&gpio 313 0>;
- };
-
- fan7 {
- label = "fan7 presence";
- linux,code = <206>;
- gpios = <&gpio 314 0>;
- };
-
- fan8 {
- label = "fan8 presence";
- linux,code = <207>;
- gpios = <&gpio 315 0>;
- };
-
- fan9 {
- label = "fan9 presence";
- linux,code = <208>;
- gpios = <&gpio 316 0>;
- };
-
- fan10 {
- label = "fan10 presence";
- linux,code = <209>;
- gpios = <&gpio 317 0>;
- };
-
- fan11 {
- label = "fan11 presence";
- linux,code = <210>;
- gpios = <&gpio 318 0>;
- };
-
- fan12 {
- label = "fan12 presence";
- linux,code = <211>;
- gpios = <&gpio 319 0>;
- };
-
- fan13 {
- label = "fan13 presence";
- linux,code = <212>;
- gpios = <&gpio 320 0>;
- };
-
- fan14 {
- label = "fan14 presence";
- linux,code = <213>;
- gpios = <&gpio 321 0>;
- };
-
- fan15 {
- label = "fan15 presence";
- linux,code = <214>;
- gpios = <&gpio 322 0>;
- };
-
- fan16 {
- label = "fan16 presence";
- linux,code = <215>;
- gpios = <&gpio 323 0>;
+ gpios = <&xreg 60 1>;
};
};
@@ -641,6 +614,12 @@
linux,code = <201>;
gpios = <&gpio 251 1>;
};
+
+ PortOwner@2 {
+ label = "Port Owner";
+ linux,code = <202>;
+ gpios = <&gpio 252 1>;
+ };
};
vuhc0: vuhc@80400080 {
@@ -659,7 +638,7 @@
interrupts = <13>;
interrupt-parent = <&vic1>;
vdevnum = <0>;
- fepnum = <7>;
+ fepnum = <4>;
udcg-handle = <&udcg>;
};
@@ -669,7 +648,17 @@
interrupts = <13>;
interrupt-parent = <&vic1>;
vdevnum = <1>;
- fepnum = <7>;
+ fepnum = <4>;
+ udcg-handle = <&udcg>;
+ };
+
+ udc2: udc@80403000 {
+ compatible = "hpe, gxp-udc";
+ reg = <0x80403000 0x1000>;
+ interrupts = <13>;
+ interrupt-parent = <&vic1>;
+ vdevnum = <2>;
+ fepnum = <4>;
udcg-handle = <&udcg>;
};
@@ -682,6 +671,13 @@
compatible = "hpe,gxp-power";
psu_phandle = <&psu1>, <&psu2>;
};
+
+ peci: peci@80000400 {
+ compatible = "hpe,gxp-peci";
+ reg = <0x80000400 0x200>;
+ interrupts = <22>;
+ interrupt-parent = <&vic1>;
+ };
};
clocks {
diff --git a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc_%.bbappend b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc_%.bbappend
index 57be249c9..4a6250ecb 100644
--- a/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc_%.bbappend
+++ b/meta-hpe/meta-dl360poc/recipes-kernel/linux/linux-obmc_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-obmc:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-obmc:"
SRC_URI += "file://gxp.dts \
"
-do_patch_append() {
+do_patch:append() {
for DTB in "${KERNEL_DEVICETREE}"; do
DT=`basename ${DTB} .dtb`
if [ -r "${WORKDIR}/${DT}.dts" ]; then
diff --git a/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
index ad672452a..fc239be98 100644
--- a/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
+++ b/meta-hpe/meta-dl360poc/recipes-phosphor/image/obmc-phosphor-image.bbappend
@@ -1,5 +1,3 @@
-
-
do_generate_hpe_image() {
# Add gxp-bootblock to hpe-section
dd bs=1k conv=notrunc seek=64 \