summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-gxp/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-hpe/meta-gxp/conf')
-rw-r--r--meta-hpe/meta-gxp/conf/layer.conf12
-rw-r--r--meta-hpe/meta-gxp/conf/machine/include/gxp.inc22
-rw-r--r--meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc6
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-hpe/meta-gxp/conf/layer.conf b/meta-hpe/meta-gxp/conf/layer.conf
new file mode 100644
index 000000000..eafb7badb
--- /dev/null
+++ b/meta-hpe/meta-gxp/conf/layer.conf
@@ -0,0 +1,12 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "gxp-layer"
+BBFILE_PATTERN_gxp-layer = "^${LAYERDIR}/"
+LAYERVERSION_gxp-layer = "1"
+LAYERSERIES_COMPAT_gxp-layer = "zeus warrior dunfell"
+
+GXPBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-hpe/meta-gxp/conf/machine/include/gxp.inc b/meta-hpe/meta-gxp/conf/machine/include/gxp.inc
new file mode 100644
index 000000000..8f515d99a
--- /dev/null
+++ b/meta-hpe/meta-gxp/conf/machine/include/gxp.inc
@@ -0,0 +1,22 @@
+#@TYPE: Machine
+#@NAME: HPE GXP
+#@DESCRIPTION: Common machine configuration for the HPE GXP Chip
+
+require conf/machine/include/hpe_soc.inc
+
+UBOOT_ARCH ?= "arm"
+
+DISTRO_FEATURES ?= "ipv4 ipv6"
+
+SOC_FAMILY = "gxp-b1"
+include conf/machine/include/soc-family.inc
+MACHINEOVERRIDES .= ":gxp"
+
+DEFAULTTUNE ?= "armv6-novfp"
+require conf/machine/include/arm/arch-armv6.inc
+
+UBOOT_MACHINE = "gxp_defconfig"
+UBOOT_ENTRYPOINT = "0x40100000"
+UBOOT_LOADADDRESS = "0x40100000"
+
+
diff --git a/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc b/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc
new file mode 100644
index 000000000..016d9c675
--- /dev/null
+++ b/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc
@@ -0,0 +1,6 @@
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-obmc"
+
+PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-gxp"
+PREFERRED_PROVIDER_u-boot ?= "u-boot-gxp"
+//PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-gxp"
+