summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-palmetto/recipes-phosphor/sensors
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-palmetto/recipes-phosphor/sensors')
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%.bbappend13
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@100/occ-hwmon@50.conf40
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@40/rtc@68.conf3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@c0/tmp423@4c.conf7
4 files changed, 63 insertions, 0 deletions
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
new file mode 100644
index 000000000..e904dc0e1
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+NAMES = " \
+ i2c@1e78a000/i2c-bus@40/rtc@68 \
+ i2c@1e78a000/i2c-bus@c0/tmp423@4c \
+ i2c@1e78a000/i2c-bus@100/occ-hwmon@50 \
+ "
+ITEMSFMT = "ahb/apb/{0}.conf"
+
+ITEMS = "${@compose_list(d, 'ITEMSFMT', 'NAMES')}"
+
+ENVS = "obmc/hwmon/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "${@compose_list(d, 'ENVS', 'ITEMS')}"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@100/occ-hwmon@50.conf b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@100/occ-hwmon@50.conf
new file mode 100644
index 000000000..40c4d7866
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@100/occ-hwmon@50.conf
@@ -0,0 +1,40 @@
+MODE_temp1 = "label"
+MODE_temp2 = "label"
+MODE_temp3 = "label"
+MODE_temp4 = "label"
+MODE_temp5 = "label"
+MODE_temp6 = "label"
+MODE_temp7 = "label"
+MODE_temp8 = "label"
+MODE_temp9 = "label"
+MODE_temp10 = "label"
+MODE_temp11 = "label"
+MODE_temp12 = "label"
+MODE_temp13 = "label"
+MODE_temp14 = "label"
+MODE_temp15 = "label"
+MODE_temp16 = "label"
+MODE_temp17 = "label"
+MODE_temp18 = "label"
+LABEL_temp13 = "cpu0"
+LABEL_temp101 = "centaur0"
+LABEL_temp102 = "dimm0"
+LABEL_temp103 = "dimm1"
+LABEL_temp104 = "dimm2"
+LABEL_temp105 = "dimm3"
+LABEL_temp106 = "core0"
+LABEL_temp107 = "core1"
+LABEL_temp108 = "core2"
+LABEL_temp109 = "core3"
+LABEL_temp110 = "core4"
+LABEL_temp111 = "core5"
+LABEL_temp112 = "core6"
+LABEL_temp113 = "core7"
+LABEL_temp114 = "core8"
+LABEL_temp115 = "core9"
+LABEL_temp116 = "core10"
+LABEL_temp117 = "core11"
+LABEL_power1 = "cpu0"
+LABEL_power2 = "pcie"
+LABEL_power3 = "io"
+LABEL_power4 = "centaur0"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@40/rtc@68.conf b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@40/rtc@68.conf
new file mode 100644
index 000000000..8b6053e33
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@40/rtc@68.conf
@@ -0,0 +1,3 @@
+LABEL_temp1=rtc
+WARNLO_temp1=10000
+WARNHI_temp1=35000
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@c0/tmp423@4c.conf b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@c0/tmp423@4c.conf
new file mode 100644
index 000000000..3166f32f1
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/sensors/phosphor-hwmon%/obmc/hwmon/ahb/apb/i2c@1e78a000/i2c-bus@c0/tmp423@4c.conf
@@ -0,0 +1,7 @@
+LABEL_temp1=ambient
+WARNLO_temp1=10000
+WARNHI_temp1=40000
+
+LABEL_temp2=cpu
+WARNLO_temp2=10000
+WARNHI_temp2=80000