summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-romulus')
-rw-r--r--meta-ibm/meta-romulus/conf/layer.conf2
-rw-r--r--meta-ibm/meta-romulus/conf/local.conf.sample92
-rw-r--r--meta-ibm/meta-romulus/recipes-kernel/linux/linux-aspeed_%.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb10
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb6
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/configuration/romulus-yaml-config.bb4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/console/obmc-console_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/flash/phosphor-software-manager_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb8
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/images/obmc-phosphor-image.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/mboxd/mboxd_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend4
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend8
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend4
27 files changed, 112 insertions, 72 deletions
diff --git a/meta-ibm/meta-romulus/conf/layer.conf b/meta-ibm/meta-romulus/conf/layer.conf
index 2c176f432..3651ada69 100644
--- a/meta-ibm/meta-romulus/conf/layer.conf
+++ b/meta-ibm/meta-romulus/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "romulus-layer"
BBFILE_PATTERN_romulus-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_romulus-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_romulus-layer = "hardknott honister"
diff --git a/meta-ibm/meta-romulus/conf/local.conf.sample b/meta-ibm/meta-romulus/conf/local.conf.sample
index 17233dff9..e600acace 100644
--- a/meta-ibm/meta-romulus/conf/local.conf.sample
+++ b/meta-ibm/meta-romulus/conf/local.conf.sample
@@ -2,7 +2,9 @@
# This file is your local configuration file and is where all local user settings
# are placed. The comments in this file give some guide to the options a new user
# to the system might want to change but pretty much any configuration option can
-# be set in this file.
+# be set in this file. More adventurous users can look at local.conf.extended
+# which contains other examples of configuration which can be placed in this file
+# but new users likely won't need any of them initially.
#
# Lines starting with the '#' character are commented out and in some cases the
# default values are provided as comments to show people example syntax. Enabling
@@ -85,15 +87,15 @@ DISTRO ?= "openbmc-openpower"
PACKAGE_CLASSES ?= "package_rpm"
#
-# SDK/ADT target architecture
+# SDK target architecture
#
-# This variable specifies the architecture to build SDK/ADT items for and means
+# This variable specifies the architecture to build SDK items for and means
# you can build the SDK packages for architectures other than the machine you are
# running the build on (i.e. building i686 packages on an x86_64 host).
-# Supported values are i686 and x86_64
+# Supported values are i686, x86_64, aarch64
#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " *"
+SANITY_TESTED_DISTROS:append ?= " *"
#
# Extra image configuration defaults
@@ -103,6 +105,8 @@ SANITY_TESTED_DISTROS_append ?= " *"
# variable can contain the following options:
# "dbg-pkgs" - add -dbg packages for all installed packages
# (adds symbol information for debugging/profiling)
+# "src-pkgs" - add -src packages for all installed packages
+# (adds source code for debugging)
# "dev-pkgs" - add -dev packages for all installed packages
# (useful if you want to develop against libs in the image)
# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
@@ -110,14 +114,14 @@ SANITY_TESTED_DISTROS_append ?= " *"
# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
# "tools-debug" - add debugging tools (gdb, strace)
# "eclipse-debug" - add Eclipse remote debugging support
-# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
# "debug-tweaks" - make an image suitable for development
# e.g. ssh root access has a blank password
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
#
# Additional image features
@@ -126,20 +130,18 @@ EXTRA_IMAGE_FEATURES = "debug-tweaks"
# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-prelink' in order to prelink the filesystem image
-# - 'image-swab' to perform host system intrusion detection
-# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
-# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-prelink"
+USER_CLASSES ?= "buildstats"
#
# Runtime testing of images
#
# The build system can test booting virtual machine images under qemu (an emulator)
-# after any root filesystems are created and run tests against those images. To
-# enable this uncomment this line. See classes/testimage(-auto).bbclass for
-# further details.
-#TEST_IMAGE = "1"
+# after any root filesystems are created and run tests against those images. It can also
+# run tests against any SDK that are built. To enable this uncomment these lines.
+# See classes/test{image,sdk}.bbclass for further details.
+#IMAGE_CLASSES += "testimage testsdk"
+#TESTIMAGE_AUTO_qemuall = "1"
+
#
# Interactive shell configuration
#
@@ -164,12 +166,12 @@ PATCHRESOLVE = "noop"
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less than 100MB or 1K inodes, perform a hard abort
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necessary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
@@ -182,7 +184,7 @@ BB_DISKMON_DIRS = "\
#
# Shared-state files from other locations
#
-# As mentioned above, shared state files are prebuilt cache data objects which can
+# As mentioned above, shared state files are prebuilt cache data objects which can be
# used to accelerate build time. This variable can be used to configure the system
# to search other mirror locations for these objects before it builds the data itself.
#
@@ -197,19 +199,57 @@ BB_DISKMON_DIRS = "\
#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
#file://.* file:///some/local/dir/sstate/PATH"
+#
+# Yocto Project SState Mirror
+#
+# The Yocto Project has prebuilt artefacts available for its releases, you can enable
+# use of these by uncommenting the following line. This will mean the build uses
+# the network to check for artefacts at the start of builds, which does slow it down
+# equally, it will also speed up the builds by not having to build things if they are
+# present in the cache. It assumes you can download something faster than you can build it
+# which will depend on your network.
+#
+#SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/2.5/PATH;downloadfilename=PATH"
#
# Qemu configuration
#
-# By default qemu will build with a builtin VNC server where graphical output can be
-# seen. The two lines below enable the SDL backend too. This assumes there is a
-# libsdl library available on your build system.
-#PACKAGECONFIG_append_pn-qemu-native = " sdl"
-#PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
-#ASSUME_PROVIDED += "libsdl-native"
+# By default native qemu will build with a builtin VNC server where graphical output can be
+# seen. The line below enables the SDL UI frontend too.
+#PACKAGECONFIG:append:pn-qemu-system-native = " sdl"
+# By default libsdl2-native will be built, if you want to use your host's libSDL instead of
+# the minimal libsdl built by libsdl2-native then uncomment the ASSUME_PROVIDED line below.
+#ASSUME_PROVIDED += "libsdl2-native"
+# You can also enable the Gtk UI frontend, which takes somewhat longer to build, but adds
+# a handy set of menus for controlling the emulator.
+#PACKAGECONFIG:append:pn-qemu-system-native = " gtk+"
+
+#
+# Hash Equivalence
+#
+# Enable support for automatically running a local hash equivalence server and
+# instruct bitbake to use a hash equivalence aware signature generator. Hash
+# equivalence improves reuse of sstate by detecting when a given sstate
+# artifact can be reused as equivalent, even if the current task hash doesn't
+# match the one that generated the artifact.
+#
+# A shared hash equivalent server can be set with "<HOSTNAME>:<PORT>" format
+#
+#BB_HASHSERVE = "auto"
+#BB_SIGNATURE_HANDLER = "OEEquivHash"
+
+#
+# Memory Resident Bitbake
+#
+# Bitbake's server component can stay in memory after the UI for the current command
+# has completed. This means subsequent commands can run faster since there is no need
+# for bitbake to reload cache files and so on. Number is in seconds, after which the
+# server will shut down.
+#
+#BB_SERVER_TIMEOUT = "60"
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
+CONF_VERSION = "2"
diff --git a/meta-ibm/meta-romulus/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-ibm/meta-romulus/recipes-kernel/linux/linux-aspeed_%.bbappend
index 664d7e114..b97800952 100644
--- a/meta-ibm/meta-romulus/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
-SRC_URI_append_romulus = " file://romulus.cfg"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
+SRC_URI:append:romulus = " file://romulus.cfg"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
index f7ed43038..36b77a03d 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-RDEPENDS_${PN} += "i2c-tools bash"
+RDEPENDS:${PN} += "i2c-tools bash"
S = "${WORKDIR}"
SRC_URI += "file://avsbus-enable.sh \
@@ -27,7 +27,7 @@ TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"
-SYSTEMD_SERVICE_${PN} += "${TMPL_EN}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_SERVICE_${PN} += "${TMPL_DIS}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "${TMPL_EN}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "${TMPL_DIS}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
index f0e6eb0ea..f25f35442 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-RDEPENDS_${PN} += "i2c-tools bash"
+RDEPENDS:${PN} += "i2c-tools bash"
S = "${WORKDIR}"
SRC_URI += "file://vrm-control.sh \
@@ -23,5 +23,5 @@ INSTFMT = "vrm-control@{0}.service"
TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/configuration/romulus-yaml-config.bb b/meta-ibm/meta-romulus/recipes-phosphor/configuration/romulus-yaml-config.bb
index 026471f7e..3638f709c 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/configuration/romulus-yaml-config.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/configuration/romulus-yaml-config.bb
@@ -28,11 +28,11 @@ do_install() {
${D}${datadir}/${BPN}/ipmi-sensors.yaml
}
-FILES_${PN}-dev = " \
+FILES:${PN}-dev = " \
${datadir}/${BPN}/ipmi-extra-properties.yaml \
${datadir}/${BPN}/ipmi-fru-read.yaml \
${datadir}/${BPN}/ipmi-inventory-sensors.yaml \
${datadir}/${BPN}/ipmi-sensors.yaml \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/console/obmc-console_%.bbappend
index 4db6f3a6d..451d82089 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
index 781af4fcf..b100be794 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
index 781af4fcf..b100be794 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
index 83b54c418..457d039e4 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 781af4fcf..b100be794 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index 781af4fcf..b100be794 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index 18f76ee3a..1aaafb5bb 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -1 +1 @@
-PACKAGECONFIG_append_romulus = " verify_signature"
+PACKAGECONFIG:append:romulus = " verify_signature"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
index 6251786c3..a7bebeb1c 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
S = "${WORKDIR}"
SRC_URI += "file://toggle_identify_led.sh"
@@ -17,7 +17,7 @@ do_install() {
${D}${bindir}/toggle_identify_led.sh
}
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button"
ID_BUTTON_SERVICE = "id_button"
@@ -26,5 +26,5 @@ INSTFMT = "phosphor-gpio-monitor@{0}.service"
TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
+SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
index bc7e02ea0..43497f33b 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/host/p9-host-start.bbappend
@@ -1,2 +1,2 @@
-RDEPENDS_${PN}_append_romulus = " avsbus-control"
-RDEPENDS_${PN}_append_romulus = " vrm-control"
+RDEPENDS:${PN}:append:romulus = " avsbus-control"
+RDEPENDS:${PN}:append:romulus = " vrm-control"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/images/obmc-phosphor-image.bbappend
index ccf7b4582..ef87ad804 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1 +1 @@
-OBMC_IMAGE_EXTRA_INSTALL_append_romulus = " mboxd liberation-fonts uart-render-controller"
+OBMC_IMAGE_EXTRA_INSTALL:append:romulus = " mboxd liberation-fonts uart-render-controller"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
index 0c4b56f72..1b5a119b1 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -14,4 +14,4 @@ do_install() {
install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
}
-FILES_${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
+FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index d552f5763..7445c4e9e 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -1 +1 @@
-DEPENDS_append = " inventory-cleanup"
+DEPENDS:append = " inventory-cleanup"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
index 73c50cf25..ad060bf7f 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
@@ -1,5 +1,5 @@
-DEPENDS_append_romulus = " romulus-yaml-config"
+DEPENDS:append:romulus = " romulus-yaml-config"
-EXTRA_OECONF_romulus = " \
+EXTRA_OECONF:romulus = " \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-inventory-sensors.yaml \
"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 4db6f3a6d..451d82089 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 79df7f399..bbdd2b241 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -1,6 +1,6 @@
-DEPENDS_append_romulus = " romulus-yaml-config"
+DEPENDS:append:romulus = " romulus-yaml-config"
-EXTRA_OECONF_romulus = " \
+EXTRA_OECONF:romulus = " \
YAML_GEN=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-fru-read.yaml \
PROP_YAML=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-extra-properties.yaml \
"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index 25130a586..7a27e223d 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -1,6 +1,6 @@
-DEPENDS_append_romulus = " romulus-yaml-config"
+DEPENDS:append:romulus = " romulus-yaml-config"
-EXTRA_OECONF_romulus = " \
+EXTRA_OECONF:romulus = " \
SENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-sensors.yaml \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-inventory-sensors.yaml \
FRU_YAML_GEN=${STAGING_DIR_HOST}${datadir}/romulus-yaml-config/ipmi-fru-read.yaml \
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/mboxd/mboxd_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/mboxd/mboxd_%.bbappend
index 566fc6c34..4e1ac7544 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/mboxd/mboxd_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/mboxd/mboxd_%.bbappend
@@ -1 +1 @@
-MBOXD_FLASH_SIZE_romulus = "64M"
+MBOXD_FLASH_SIZE:romulus = "64M"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 6380ac256..69588edb0 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,2 +1,2 @@
-RDEPENDS_${PN}-inventory_append_romulus = " openpower-occ-control id-button"
-RDEPENDS_${PN}-extras_append_romulus = " phosphor-webui phosphor-image-signing"
+RDEPENDS:${PN}-inventory:append:romulus = " openpower-occ-control id-button"
+RDEPENDS:${PN}-extras:append:romulus = " phosphor-webui phosphor-image-signing"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index 3aba6bbb8..703cac279 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
-EXTRA_OEMESON_append_romulus = " -Dnegative-errno-on-fail=true"
+EXTRA_OEMESON:append:romulus = " -Dnegative-errno-on-fail=true"
CHIPS = " \
bus@1e78a000/i2c-bus@440/w83773g@4c \
@@ -21,5 +21,5 @@ OCCSFMT = "devices/platform/gpio-fsi/fsi0/slave@00--00/{0}.conf"
OCCITEMS = "${@compose_list(d, 'OCCSFMT', 'OCCS')}"
ENVS = "obmc/hwmon/{0}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}_append_romulus = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
-SYSTEMD_ENVIRONMENT_FILE_${PN}_append_romulus = " ${@compose_list(d, 'ENVS', 'OCCITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:romulus = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}:append:romulus = " ${@compose_list(d, 'ENVS', 'OCCITEMS')}"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 4db6f3a6d..451d82089 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 308c73189..11a2b498b 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:romulus := "${THISDIR}/${PN}:"
-EXTRA_OEMESON_romulus += "-Dwarm-reboot=disabled"
+EXTRA_OEMESON:romulus += "-Dwarm-reboot=disabled"