summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch94
1 files changed, 94 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch b/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch
new file mode 100644
index 000000000..86362db15
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Add-witherspoon-128-machine.patch
@@ -0,0 +1,94 @@
+From 4c69603d48eebce36aedd28fc572bb43c1146f9c Mon Sep 17 00:00:00 2001
+From: Eddie James <eajames@linux.ibm.com>
+Date: Wed, 2 Oct 2019 10:13:36 -0500
+Subject: [PATCH] ARM: dts: Aspeed: Add witherspoon-128 machine
+
+Create a witherspoon machine with 128MB flash chips.
+
+Signed-off-by: Eddie James <eajames@linux.ibm.com>
+---
+ arch/arm/boot/dts/Makefile | 1 +
+ .../dts/aspeed-bmc-opp-witherspoon-128.dts | 59 +++++++++++++++++++
+ 2 files changed, 60 insertions(+)
+ create mode 100644 arch/arm/boot/dts/aspeed-bmc-opp-witherspoon-128.dts
+
+diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+index 3ad9706337a2..7f60d157ef5d 100644
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -1292,6 +1292,7 @@ dtb-$(CONFIG_ARCH_ASPEED) += \
+ aspeed-bmc-opp-tacoma.dtb \
+ aspeed-bmc-opp-vesnin.dtb \
+ aspeed-bmc-opp-witherspoon.dtb \
++ aspeed-bmc-opp-witherspoon-128.dtb \
+ aspeed-bmc-opp-zaius.dtb \
+ aspeed-bmc-portwell-neptune.dtb \
+ aspeed-bmc-quanta-q71l.dtb
+diff --git a/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon-128.dts b/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon-128.dts
+new file mode 100644
+index 000000000000..1ba673a49334
+--- /dev/null
++++ b/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon-128.dts
+@@ -0,0 +1,59 @@
++// SPDX-License-Identifier: GPL-2.0-or-later
++// Copyright 2019 IBM Corp.
++/dts-v1/;
++
++#include "aspeed-bmc-opp-witherspoon.dts"
++
++&fmc {
++ status = "okay";
++
++ flash@0 {
++ status = "okay";
++ label = "bmc";
++ m25p,fast-read;
++ spi-max-frequency = <100000000>;
++
++ partitions {
++ #address-cells = < 1 >;
++ #size-cells = < 1 >;
++ compatible = "fixed-partitions";
++ u-boot@0 {
++ reg = < 0 0x60000 >;
++ label = "u-boot";
++ };
++ u-boot-env@60000 {
++ reg = < 0x60000 0x20000 >;
++ label = "u-boot-env";
++ };
++ obmc-ubi@80000 {
++ reg = < 0x80000 0x7F80000>;
++ label = "obmc-ubi";
++ };
++ };
++ };
++
++ flash@1 {
++ status = "okay";
++ label = "alt-bmc";
++ m25p,fast-read;
++ spi-max-frequency = <100000000>;
++
++ partitions {
++ #address-cells = < 1 >;
++ #size-cells = < 1 >;
++ compatible = "fixed-partitions";
++ u-boot@0 {
++ reg = < 0 0x60000 >;
++ label = "alt-u-boot";
++ };
++ u-boot-env@60000 {
++ reg = < 0x60000 0x20000 >;
++ label = "alt-u-boot-env";
++ };
++ obmc-ubi@80000 {
++ reg = < 0x80000 0x7F80000>;
++ label = "alt-obmc-ubi";
++ };
++ };
++ };
++};
+--
+2.23.0
+