summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/workbook
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/workbook')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb17
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config/config.yaml54
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/workbook/witherspoon-config.bb5
3 files changed, 76 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb
new file mode 100644
index 000000000..9a16dd6b3
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Witherspoon Device Tree Configuration"
+DESCRIPTION = "Provides the device tree configuration file for Witherspoon"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit native
+
+SRC_URI += "file://config.yaml"
+
+FILES_${PN} += "${datadir}/devtree"
+
+do_install() {
+ install -d ${D}${datadir}/devtree
+ install -m 0644 config.yaml ${D}${datadir}/devtree/
+}
+
+S = "${WORKDIR}"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config/config.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config/config.yaml
new file mode 100644
index 000000000..3094c164d
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config/config.yaml
@@ -0,0 +1,54 @@
+#Device tree include files, which can be
+#included in different parts of the tree.
+#Optional.
+includes:
+ pre-root-node:
+ - aspeed-g5.dtsi
+ - dt-bindings/gpio/aspeed-gpio.h
+ root-node:
+ post-root-node:
+
+#The BMC's memory base address and size.
+#Required.
+memory:
+ base: 0x80000000
+ size: 0x40000000
+
+#Enables the mapping of the host SPI flash into memory
+#and the LPC mailbox to allow host access to that data.
+#Required for most P9 OpenPower systems.
+lpc-host-spi-flash-mailbox:
+ #The address range to map the flash into
+ bmc-address-range:
+ base: 0x94000000
+ size: 0x04000000 #64MB
+
+#Values for the chosen node.
+#Required.
+chosen:
+ stdout-path: (alias)uart5
+ bootargs: console=ttyS4,115200 earlyprintk
+
+#Values for the aliases node.
+#Optional.
+aliases:
+ serial4: uart5
+
+#The number that should be added to the MRW's
+#I2C bus number to get the device tree's number.
+#Optional.
+i2c-bus-adjust: -1
+
+#BMC flash specific fields that don't belong
+#in the MRW. Keys and values here show up
+#as-is in the node structure that gets passed to
+#the node generator code.
+bmc-flash-config:
+ chip-select-0:
+ DTSI_INCLUDE: aspeed-bmc-opp-flash-layout.dtsi
+ chip-select-1:
+ label: alt
+
+#If OpenFSI device tree support should be enabled.
+#true or false
+enable-openfsi: true
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/witherspoon-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/witherspoon-config.bb
new file mode 100644
index 000000000..e08f89d25
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/witherspoon-config.bb
@@ -0,0 +1,5 @@
+SUMMARY = "Witherspoon board wiring"
+DESCRIPTION = "Board wiring information for the Witherspoon OpenPOWER system."
+PR = "r1"
+
+inherit config-in-skeleton