summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb16
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup.bb2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/swift/inventory-cleanup.yaml16
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/witherspoon/inventory-cleanup.yaml (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend1
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/channel.yaml4
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend5
8 files changed, 18 insertions, 28 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
deleted file mode 100644
index 80e6e6de5..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Copy Witherspoon inventory cleanup yaml for inventory manager"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit native
-inherit phosphor-inventory-manager
-
-SRC_URI += "file://inventory-cleanup.yaml"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -d ${D}${base_datadir}/events.d/
- install ${S}/inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
-}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup.bb
index cdb146c50..f68edcb62 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -1,4 +1,4 @@
-SUMMARY = "Copy Witherspoon inventory cleanup yaml for inventory manager"
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/swift/inventory-cleanup.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/swift/inventory-cleanup.yaml
new file mode 100644
index 000000000..a2ff9d177
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/swift/inventory-cleanup.yaml
@@ -0,0 +1,16 @@
+description: >
+ Swift inventory fixups
+
+events:
+ - name: Add Chassis interface
+ description: >
+ Add the chassis interface on the chassis inventory path
+ type: startup
+ actions:
+ - name: createObjects
+ objs:
+ /system/chassis:
+ xyz.openbmc_project.Inventory.Item.Chassis:
+ Type:
+ value: "RackMount"
+ type: string
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/witherspoon/inventory-cleanup.yaml
index a363bda8d..a363bda8d 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/inventory-cleanup.yaml
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup/witherspoon/inventory-cleanup.yaml
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend
deleted file mode 100644
index d9304c045..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PHOSPHOR_INVENTORY_MANAGER_CONFIGS += "inventory-cleanup-native"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index 9b5b948fa..39f87342e 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -3,7 +3,7 @@ PACKAGECONFIG_append = " associations"
SRC_URI += "file://associations.json"
-DEPENDS_append_witherspoon = " inventory-cleanup"
+DEPENDS_append = " inventory-cleanup"
do_install_append() {
install -d ${D}${base_datadir}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/channel.yaml b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/channel.yaml
deleted file mode 100644
index 627f4965f..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/channel.yaml
+++ /dev/null
@@ -1,4 +0,0 @@
-# Channel Number (must be unique) is the key
-1:
- # ifName the ethernet device name (used in the dbus path)
- ifName: eth0
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
index eec3999f2..bb28054c6 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -2,14 +2,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append = " \
file://occ_sensors.hardcoded.yaml \
file://hwmon_sensors.hardcoded.yaml \
- file://channel.yaml \
"
# System-specific sensors
SRC_URI_append_witherspoon = " \
file://witherspoon_hwmon_sensors.hardcoded.yaml \
"
-
-EXTRA_OECONF_append = " \
- CHANNEL_YAML_GEN=${WORKDIR}/channel.yaml \
- "