summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend')
-rw-r--r--meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend19
1 files changed, 16 insertions, 3 deletions
diff --git a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index a134e350b..0cbca65aa 100644
--- a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -1,9 +1,9 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-PACKAGECONFIG_append_rainier = " host-dump-transport-pldm"
+PACKAGECONFIG_append_p10bmc = " host-dump-transport-pldm"
PACKAGECONFIG_append_witherspoon-tacoma = " host-dump-transport-pldm"
-PACKAGECONFIG_append_rainier = " openpower-dumps-extension"
+PACKAGECONFIG_append_p10bmc = " openpower-dumps-extension"
PACKAGECONFIG_append_witherspoon-tacoma = " openpower-dumps-extension"
SRC_URI += "file://plugins.d/ibm_elogall"
@@ -33,7 +33,20 @@ install_dreport_header() {
install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
}
+#Install ibm bad vpd script from dreport/ibm.d to dreport/plugins.d
+install_ibm_bad_vpd() {
+ install -d ${D}${dreport_plugin_dir}
+ install -m 0755 ${S}/tools/dreport.d/ibm.d/badvpd ${D}${dreport_plugin_dir}
+}
+
+#Link in the plugins so dreport run them at the appropriate time based on the plugin type
+python link_ibm_bad_vpd() {
+ sourcedir = d.getVar('S', True)
+ script = os.path.join(sourcedir, "tools", "dreport.d", "ibm.d", "badvpd")
+ install_dreport_user_script(script, d)
+}
+
IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
-IBM_INSTALL_POSTFUNCS_rainier += "install_dreport_header"
+IBM_INSTALL_POSTFUNCS_p10bmc += "install_dreport_header install_ibm_bad_vpd link_ibm_bad_vpd"
do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"